Output Surface Smoothness

Hi Everyone,

I seem to have an issue that I don’t really know how to fix, I’m not sure if it’s even a grasshopper problem.

I had a surface built in rhino with the control points adjusted in height to create a waved surface (white) and have tried to recreate this effect in grasshopper by creating an input surface, rebuilding it in GH and moving the control points (Orange) or creating a new grid of points in GH, moving those points and then creating a surface from those points (Blue).

The issue is that these baked surfaces from grasshopper, as shown in the zebra analysis, are not very smooth and show lots of jagged artefacts.

Am I doing something wrong? (Probably)
Is there a way to smooth them out again in GH or Rhino?

Thanks, Peter


2021-08-31 Surface Wibble.gh (18.2 KB)

A Nurbs surface with degree > 1 and no overlapping points is always smooth.
(please anybody feel free to correct me)
But, the software will not compute pixel-by-pixel the correct representation of that nurbs object, that would take too many resources, like the evaluation of a fractal.
It will, instead, create a mesh object as substitute, that is used only for viewing/displaying. That is the “meshing”.
2021-08-31 16_45_23-Window

(Usually rhino will silently save in your file those “Rendering Meshes” of all your nurbs surface/polysurface objects to have them ready the next time you open it. You can avoid that if you use “Save Small” or with the options while you “Save As…”)

See here: Rhino Mesh Settings - Detailed Info [McNeel Wiki]


You are talking about Zebra function? That’s Rhino context.
Zebra function will create custom meshes (usually with higher quality) to display the zebra.
You simply have low quality settings for your meshes. Increase it.
See the "Adjust Mesh… " button:


Even grasshopper can have similar situations.
Grasshopper use the rhino meshing parameters (Options>Mesh), but some component might have its own controls for it or simply use a mesh.

Thank you very much for the info Riccardo.

I had increased the mesh quality in rhino with the basic options, I didn’t realise that max edge length in the detailed options would make such a difference - it seems to solve the problem!

The issue seemed to be that creating the same “quality” of surface in GH as the original rhino surface in terms of degree, point count, mesh settings - the output surfaces from GH seem to be noticably worse than the original, so I wasn’t sure if it was an effect from the GH proccess.