OT: Really odd crash and shutdown


#1

I don’t think this has anything to do with Rhino, but if it has happened to others then it is of interest.

I just had the oddest experience, Rhino threw an error I had never seen before, and it flashed too fast for me to remember it, then Windows logged off, shut down, restarted and when I logged back in it reopened Google Crome and Outlook automatically…

I have never experienced Windows to re open programs after a log off-log on.

First I thought it was a Windows update thing that had “forgotten” to tell me that it would shut down, but it was not like that either.

Anyone with a similar experience?
Any modern software I should run to scan for any malware?


#2

Oh, and no autosave… even though I have worked on the file for 40+ minutes.
It should have saved twice, and it is a very small possibility that the autosave is the issue, that I had worked for exactly 40 minutes, but that isn’t very likely, probably just a matter of coincidence, but nice to have on record none the less.


#3

Sounds like it might have been some irrecoverable graphics driver error, it’s about the only thing I can imagine that could cause a hard reboot like that? Dunno, I’m no expert in this stuff, but there is an error log in Windows - Event Viewer - to look at that will have recorded the event. it’s somewhat hard to decipher IIRC.

–Mitch


#4

Thanks, the log had no traces of the event that I could find. But .Net was updated today and it needed a restart.

The oddest thing was that it restarted internet and outlook after login, I have never seen that before after a log off. Windows should not be able to do that… Either it logs of and restarts OR it hibernates. And the restart was FAST.


(Wim Dekeyser) #5

That happened to me 2 days ago as well. I was very surprised, too, to see programs starting up by themselves after a shut-down…


#6

Just to be sure; did you have Google Chrome and Outlook open when the shutdown occurred ? Which version of Windows were you running?

I’ve always done Windows updates manually, so I don’t know much about what it does when fully automatic.

I do know that when I install an update to Intel Parallel Studio a restart is required and when I log back in Explorer comes up automatically with a “Getting Started” help page.

I’m no expert, but I think that when a restart is requested of Windows it is possible, if desired, for the requesting program to write a .bat (or modern equivalent) file which is automatically run on the next boot up.

Could there have been something along those lines that happened?


#7

Yes, Rhino, Outlook and Crome was running when this happened. I presume Rhino threw an error code due to the shutdown. Neither Outlook nor Crome showed any info regarding the procedure when they were started.

@wim maybe it’s a Norwegian thing… :wink:


(Wim Dekeyser) #8

A Norwegian flue, yes…
In my case there hadn’t been an update that required a reboot. I get those messages once in a while, saying that a reboot is needed within the next 24 (or so?) hours [I always completely shut down when I’m done so that’s never a problem], but nothing like that happened that day…


(John Brock) #9

This sounds like the Nvidia Quadro driver crashes that have been such a problem over the last year. Rhino doesn’t even need to be running.
If this is it, the reason there is no autosave file is Rhino has not crashed. It is waiting for a display driver that Windows has killed and isn’t coming back.


(Wim Dekeyser) #10

Quadro here, yes. And I don’t think, though not totally sure, that Rhino was running. I wrote down that I was watching a Grasshopper tutorial video at the time. [I have a start-up batch script that registers time and server I’m connected to on each boot-up. This leaves a text file open in notepad and allows me to quickly add a comment in case I’m doing something special or, as in this case, the PC does something weird…]


#11

My laptop has a Geforce 330m so no Quadro here.
And I was not aware of any updates, but when I looked at the event log I saw that there was a post that said it had installed a .Net 4.5 upgrade that needed a restart. But no visual warning.

Odd, and the strange thing was also that the warning was different, it wasn’t a typical Rhino warning, it looked more like an older systemwarning that said that Rhino had encountered a problem. (I don’t really know what I mean by “older” it was more the feel I got, it disappeared too fast for me to reflect over it, so don’t pay too much attention to that, but it might give a clue to someone.)