Origami pattern with additional application of force

unhandled

(Mariya Anishchenko) #1

Hi everyone!
I’m new in Kangaroo and try to do my first project. My aim is to create an origami pattern and to apply extra forces from 2 points and I cannot understand how to do it.
I have already done the origami itself using advice from some old topics on the forum (I attach the .gh file), but now try to apply extra forces. To understand what I mean please have a look at the pictures below. the first one - is what is already done, and the second one is what I am trying to do.
I tried to add some forces adding them directly to the Kangaroo Physics component together with forces of folding, but it didn’t work.
Any ideas of how it can be done?


origami pattern.gh (46.7 KB)


(Pooria Tavakoly) #2

hi maria
could you say how you define your mesh of flat folding pattern, I’m working on something like this and i cant to define my mesh with specific facades that i looking for well.


(Mariya Anishchenko) #3

Hi Pooria!

To define mesh I use Weavebird component (it is another plugin for grasshoper) wbWeave. It creates mesh from lines. You can see it in the file which i have attached in the initial post.


(Pooria Tavakoly) #4

tnx for reply mariya
actually i knew already weaverbird, and use it for this issue too.
but its now working for me yet,
i take a look at your file and try to find out where is the problem in my work


(Mariya Anishchenko) #5

It didn’t work for me too from the beginning. I had to remove all the open lines from the list ( i mean those ones, which didn’t form a closed space) and also flatten the input.


(Pooria Tavakoly) #6

i couldn’t figure it out,
i checked my curves again and cant find any problem, i baked my mesh beside of wb mesh in image below for clarify the issue.
any idea?
Origami_thesis.gh (45.8 KB)


(Mariya Anishchenko) #7

Pooria, I opened your script and it works, but looks strange… I could launch the solver without problems even though the mesh looks the same as on your picture and it is strange. It seems that the wb makes some triangles double, but i do not know how to avoid it, sorry…


(Daniel Piker) #8

It looks like your problems stem from the way the initial curves are drawn - they are not all properly connected at the vertices - for example if you zoom in you can see situations like this:
image image

This then results in a non-manifold mesh being created.

The best solution would be to redraw the curves, making sure only the correct OSnap options are turned on to avoid accidentally snapping to the wrong thing (so here probably you probably just want ‘End’, and definitely switch ‘Near’ off).

A more brute force way to fix this is to use the ‘topologizer’ component (which you can find here), but much better to create clean input in the first place.
I’ll also try and post soon an example of how you can solve this in the current version of Kangaroo.
Origami_clean_input.gh (47.3 KB)


(Pooria Tavakoly) #9

tnx Daniel
i should guess myself its cause of something like this,
its great to see your example in the current version of kangaroo,
i waiting for that.