Opening Heavy CAD Files

SystemInfo is critical here, ensuring you have OpenGL properly configured as well as plugins.

Lots of objects can be problematic, especially if they are far from the origin.

Initial render mesh typically takes the longest time, so turning off superfluous geometry, saving in wireframe will help it open quicker.

Hey, thanks for your help. It’s a 20mb .dwg I’m trying to open. I’ve opened similar files on other computers. The file isn’t corrupt just really heavy - hatches, blocks, xrefs etc. I’ve attached SystemInfo as requested.
SystemInfo.txt (1.8 KB)

Hey, thanks for your help. The .dwg I’m trying to open is just 2d with no meshes. The graphics are far from the origin though. If I can’t resolve this I’ll need to tell sender to clean up their CAD. But typically this falls into my scope. I’ve attached System Info.
SystemInfo.txt (1.8 KB)

OpenGL is on the bigger card & no plugins. Can you send us the file for testing?

upload privately to McNeel.


Sure, I’ve uploaded the file using link provided.

Do you mean my laptop is reading the wrong/smaller card for open GL? Meaning I need to tell rhino to read the larger GTX 3080? How best to configure open GL?

Which plugins do you recommend?

You’re fine, the problem is when Performance Settings cause the 1 gb card to be used for openGL.

There are definitely some ‘must have’ plugins, but it really is workflow dependent.

Clipper is essential, as is this simple one for blocks

Ah fantastic article! Thanks very much for sharing. Ok, I’ll check out these plugins. Thanks again!

It’s was a little slow to import (about a minute), a fair amount text & hatches.

The autocad objects are around 578144969.57 feet from the origin.

Ok, thanks for checking. I’ll now try to open again as I’ve just gone through the steps outlined in the article.

Unfortunately my reconfigured laptop is still struggling to open this file. Are your specs really high on the machine you’re using?

Interestingly though, I’ve learnt that if I import the file instead of open - it opens as expected. However when I zoom extents the same struggle starts. The difference is that ‘open’ starts the file at extents whereas import starts with nothing to read on the screen.

You’re looking a lot better in a spec comparison.

My System Info

Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Commercial, build 2022-07-27
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 Super (NVidia) Memory: 8GB, Driver date: 6-23-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 516.59
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-23-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Before you zoom extents SelText, SelHatch, SelDims and hide, or turn off the layers and leave only what is critical.


Interesting. What could be hanging this up then do you think? I just tried opening again but 15 mins in I gave up. If it’s not spec it must be some hidden setting?

Ok, I’ll try those commands but unfortunately the commands take ages too, especially as many of the hatches are embedded in blocks, so I need to explode first.

Hi Adam - what happens if you turn GPU Tessellation down to the minimum in Options > View > OpenGL?


Thats a big difference in what i’m seeing. What units is the file you are inserting into? with being so far from the origin it could be a factor, my default is feet.

Hey Pascal, I have 2 options here. 1. GPU Tessellation on/off. 2. Antialiasing set at 4x. Should I try switching tess off?

I typically use default mm. I switched it to feet but same problem. hmm

I can insert the dwg in about 35 seconds, Cntl A and hiding everything is seamless.

This seems graphics related, but do note i am opening off my hard drive.

I’m also opening off my SSD hard drive. Totally lost with this one then. Hopefully we can get this resolved.

Would you mind sharing a link to the clipper plugin you mentioned? I found this on food4rhino:

Is this the one? I couldn’t find it on my toolbars though + ‘clipper’ shortcut didn’t show any results.

I also found this one:

Do you use this?

I was just curious about the gpu tessellation - I would try with that slider all thew way left, or un-checked, if you have not.


Type PackageManager in the command line and search for Clipper

Turning down/Off the GPU Tessellation did nothing?

The variables here is Video Driver and Rhino Version. Lets start with Rhino, you’re on 7.1, current version is 7.21