Open5x Grasshopper

I’ve been trying to figure out how to operate this guy’s open5x:

The grasshopper file that I am working with is called open5x_supportless_slicing_ver2.gh

The rhino file that I am working with is called Supportless_sample_2.3dm

I got the 5-axis printer all set up. Problem is this guy’s grasshopper is confusing.

I’m a beginner in Rhino and Grasshopper. Have no experience in CAD or coding.

In the author’s grasshopper file there are a bunch of orange boxes and wires as well as one red box.

I tried using google and ChatGPT to figure out what the errors mean, but I have no clue in changing the input stuff.

Any tips thank you!

Do you have Heteroptera installed?

Everything worked on the first try for me once i pushed the button

Yes, I have Heteroptra 0.7.3.5 installed

I am using the trial license version of Rhino 7.

Could you tell me the steps you did to get everything to work? Maybe I’m doing something wrong on my end. Sorry! complete beginner in Rhino and Grasshopper.

When I open the grasshopper file I get this even though I installed Heteoptera 0.7.3.5:

Then I get these windows popping up in the Grasshopper afterwards. I’m not too sure what I can do here:

image
image
image
image

After I clear those windows and opened both files, I got the grasshopper to automatically recognize the substrate and the supportless brep from the rhino CAD file and toggled it true like in your photo.

image

But then I get orange colored components on the upperside here:

I also got orange colored components and a red colored component on the lowerside here

Any help would be appreciated thank you!

I got the same warnings as well, except for the Center component, which is probably the .Net 6 dependency mentioned.

I was able to run it after cancelling the warnings & toggling to True.

Actually i misread that. How did you install Heteroptra? via package manager? or placing the .gha in the grasshopper components folder? If you placed the file you will need to right click and unblock.

1 Like

Hi Japhy,

I managed to install Heteroptra successfully with that unblock.

I downloaded .NET 6.0 as well.

So I ran the grasshopper file again and thankfully alot of the orange components and red component went away.

However, I still got this one orange component leftover. Any suggestions how to get rid of it or can I just ignore that?

Other than that would you happen to know how I can start printing this? I got a built version of this 5-axis printer. I want to print out that rhino sample, but i’m not sure how to include the grasshopper parameters. I understand that the grasshopper produces a G-code output, but i’m not too sure how to convert that into a 5-d print file.

That is splitting out a particular branch, something to do with Path without infills – seems superfluous to the big picture.

I have only a surface level knowledge of what is going on here, you will need to rely the author or someone who is familiar with the process for additional help.

Saving this file and running it on your Prusa seems to be the process.

hello, I’m trying to get the Open5x project up and running and have been trying to get around to Grasshopper for a very long time when I open a file
open5x_5axis_slicing_ver2.gh I get windows:
import 3DM
Custom preview
Custom preview
import 3DM

I tried to repeat all the steps that were written earlier
but nothing worked out for me.
any help would be appreciated, thanks in advance!