Open Edges on Models for 3D Printing

Hello All, I’ve been making simple models in Rhino where I layout some curves for a frame, and then use the surface tools to create surfaces for everything. When that’s complete I will join all the surfaces together, save the model and export the surfaces for 3D printing.

On almost every model I get open edges, Bambu Lab calls them non-manifold edges. What I can’t figure out is either what I’m doing wrong, or how to find and fix them in Rhino. The Bambu studio will fix them, but I’d rather get to the root cause of why it’s happening instead so I create them cleanly. I can provide a simple model if that will help.

Thank You
-Paul-

1 Like

Hi Paul - please post an example bad-file. Non-manifolds are where more than two faces share a joined edge.

-Pascal

Here is the model,

It’s a sample piece to plug into a hex wall attachment, there’s not much to it…

Thank You :slight_smile:
-Paul-

RulerHolder.3dm (1.5 MB)

your top part has an opening at the bottom and is not connected to the bottom part.

simply grab them both and boolean union them. It will join them up.

you can always see naked edges by running showedges and set the tool to highlight naked edges.

1 Like

Ahhh, ok that fixed it. It’s a good day when I learn something new, I’ll look up the showedges and do some playing.

Thank You so much.
-Paul-

1 Like

I have showedges in my MMB popup, it’s clutch for making sure your parts are watertight as you go.
happy modeling!
-K

2 Likes

I assume by your question you have some experience with 3d printing, but just for the sake of sharing info that exists in relevant places, check out these videos if you haven’t

That’s cool, while I prefer that button for view manipulation. I do run the show edges command quite a bit from command prompt. I really like the command prompt.

However, my main strategy I prefer is a viewport display mode that I like to call ‘work mode’ that shows as much detail as possible so ‘at a glance’ I can tell as much information as possible about the geometry I’m seeing in the viewport.

These are my current color preferences for surfaces atm:


*don’t worry the funny green line off in space is just the Y-axis of the cplane :sweat_smile:

This setup helps show the naked edges as I go, but of course I really like the showedges command to get the feedback from Rhino and see the “no naked edges, no non-manifold edges.” for verification.

Also, via command prompt I really like seeing the “polysurfaces joined into one closed polysurface.” feedback when joining stuff.

2 Likes