Open .dwg - skipped all objects

Hi All,

I tried to open the attached file. On my computer I have R5 and R6 installed but none is able to import these curves.
Any idea why this is happening?
test.dwg (114.3 KB)

What version of Autocad is that saved in? Make sure its pre 2018

Indeed i have tried all options. This one is that i have uploaded is 2012 i believe

I imagine that all the 46 objects in the file might be specialized AutoCAD objects and thus not something Rhino can read… Just a theory though.

I don’t have autocad to test, I can import into Revit and an online viewer

Can you draw a line and save as 2012 and import that?

Yes i can sketch on top and the new curves are visible in Rhino.
But the thing is that the original file it has hunders of those curves making this process not very appealing…

There are 3D polylines actually.

Can you export as DXF? That way maybe someone can open the file in a text editor and read what kind of entities they are…

Also tried the .dxf option but didnt work either
test.dxf (32.2 KB)

There are a number of techniques to convert 3D Polylines to LWPolylines.

Is there 3D information you are trying preserve? Flatten / Flatshot are an option, explode join, some autocad versions have a Convert. PEdit might work in this case as well.

I have Autocad LT and unfortunatelly Flatten is not included. That’s why i was hoping that I will be able to post process it in Rhino.
The most “dangerous” thing is that some 3D polylines are being opened in Rhino while some others were skipped. Luckily i noticed that not all curves were imported properly.