Open Block Madness


#1

This “double click a block” feature is driving me nuts.

I use a lot of linked blocks. I can’t help accidentally opening them all the time. It’s usually Rhino interpreting a couple clicks as a double click.

I’ve put up with this for over a year now without complaining because I do use the feature to edit blocks sometimes. On larger blocks, I prefer to have the block open separately and update the block where it’s inserted.

So, a few times a day, I happen to accidentally open a block and have to wait for it to open and then wait to close it. Sometimes, the Rhino instance where the block is inserted stays locked after closing the block and has to be force-quit. I don’t have tome to accommodate a “feature” like this… How about some other way to open linked blocks like through the right-click contextual menu or something? Since I use this feature more by accident than by intention, I’d disable it if I could. I hate “confirm” boxes, but in this case I’d rather have that than having blocks opening with my ADHD mouse hand.

Please, this is not a V6 wish. It was a V5 wish that was implemented poorly IMHO.

–end of rant–

Jim


(Pascal Golay) #2

This is a bug- make sure to let the second instance is fully open the file before closing it- you are likely in a hurry to close the thing if you opened it by mistake…

I’m not sure what can be done to disable double click editing in V5, but it is more possible in V6, where there is a ‘geek level’ settings file that could contain this sort of thing. I’ll put it on the list anyway. I wonder if your mouse double-click speed is set very slow or something- we don’t, I believe, hear this complaint much, if at all.

-Pascal


#3

Thanks Pascal.

Good info…

I’ll try a faster double click speed. Seems like that should do the trick.

Jim


(Pascal Golay) #4

Hi Jim- please let me know if changing the double click speed helps- I’d rather not suggest yet another setting to the developers if it is not a continuing problem.

thanks,

-Pascal


#5

I’ve played with the new mouse setting some. It seems to do the trick.

Thanks again!

Jim


(Pascal Golay) #6

Excellent, thanks for letting me know.

-Pascal