Open and Invalid brep, Brep join doesn’t work


As you can see in grasshopper script, after doing loft, some surfaces are going to open and invalid brep. brep join dosnt help me. is there any other solution for that?

Best regrads,

Without a Grasshopper file it is difficult to find what’s wrong with your definition. (49.7 KB)
That is grasshopper file.

Your objects are far from the origin, which can cause all sorts of problems. I oriented the input surfaces closer to the origin and the lofts cap.

I’m not using Pufferfish and I’m not sure what the Pufferfish loft component is doing but the native loft component seems to do the job just fine. (57.6 KB)


the issue is i dont want change the location of object.

In that case you need to move the objects close to the origin for the operation and then back to their original place. (57.3 KB)


X output of oriant is not the original location. geometriy transfered in somewhere els. :slightly_smiling_face:

@martinsiegrist needs another coffee to wake up on this Monday morning :sweat_smile: (53.7 KB)


Yes of course :slight_smile:

Thanks alot for your heping @martinsiegrist. but there is still problem, 2 branchs didnt cap.

It is capped - see the isocurves showing when the brep is baked, as well as the face being displayed if accessed with Deconstruct Brep. I tried to replace the Loft by an Extrusion, and the same thing happens.

The problem rather comes from the display meshes that fail this far form the origin. Are you building somethng on the Moon ? :smiley:


haha…it could be on the moon…

but that is unbelivble… just i merged objects one step earlier, based on first script, and now it works…

Another way to do that is creating a Vector 2pt to move the geometry to the origin and then reversing the same vector (“-x” expression) to return it to the distant location. I just don’t see any valid reason for working so far from the origin - and I’ve heard them all.