Only artifacts on display


#1

Hi,
i just installed the latest WIP and i only get artifacts displayed. Even when i start a new file, the first line doens’t shows up where it’s drawn…


In the attached image, a circle (center 0,0 radius 5) and a triangle (doted lines show correct form, only when selected)

This is my system information:
Rhino 6 SR0 2017-7-18 (Rhino WIP, 6.0.17199.12041, Git hash:master @ 9201f554befe8a516130e036d13ce4f65a915cd0)

Windows 7 SP1 (Physical RAM: 7.9Gb)

Intel® HD Graphics 4600 (OpenGL ver:4.3.0 - Build 10.18.14.4414)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 10.18.14.4414
Driver Date: 3-23-2016
Driver Version: 10.18.14.4414
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp "Commands"
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp "Renderer Development Kit"
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp "Rhino Render"
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp "RDK_EtoUI"
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI"
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp "Snapshots"
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp "Cycles for Rhino"
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp "RhinoCycles"
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp "Toolbars"
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


(Wim Dekeyser) #2

I suppose that the first thing to try is to update your GPU drivers.


(Pascal Golay) #3

Hi Heiko - can you please open Options > View > OpenGL and change the setting for ‘GPU Tessellation’ Does that make any difference?

-Pascal


#4

Problem isn’t solved with the latest drivers (support discontinued…).

Unchecking the GPU Telssellation solves the problem, thanks!


(Wim Dekeyser) #5

While that might work, it’s not really a solution :wink:
As far as I can tell, GPU tessellation should work fine for an Intel GPU running OpenGL 4.0 and later. Yours appears to be using OpenGL 4.3.0.
CC: @stevebaer


(Steve Baer) #6

Unfortunately some of the Intel drivers suffer from this problem and I have been able to repeat it. I was by default disabling GPU tessellation on Intel drivers that only supported up to GL 4.0; looks like I may have to do so with the ones that only go up to 4.3. My Intel driver supports GL 4.4 and works great with the feature.


#7

I tried the latest driver for my chipset with windows 7 support 15.36.33.4578 and the one before it 15.36.31.4414, both supporting OpenGL 4.3, same result with both, i have to disable tessellation.
In Rhino 5 there is no problem, graphic seems much faster.


(Steve Baer) #8

It’s a bug in the Intel driver and unfortunately I don’t have any good contact information at Intel to tell them about this bug. Nvidia and AMD drivers appear to work with this feature. I do know that the newer Intel Iris drivers also work with GPU tessellation enabled, but that is probably a different GPU than what you have. If it weren’t for this driver bug, I wouldn’t even make a checkbox option on the OpenGL settings page and just always keep the feature enabled.

Sorry, but I don’t have high hopes of fixing GPU tessellation for your specific GPU.


(Steve Baer) #9

All that said; wire drawing should be very similar to V5 speed when this feature is disabled.