OneView UpdateCPlane=Yes Bug

UpdateCPlane=Yes always returns to world top instead of a custom cplane setting.

OneView snaps to your custom cplane after perspective back to world top.

Using named cplanes leaves a XYZ decal on the screen.

Hi Eric - that is a setting at the command line when you run OneView.

-Pascal

UpdateCPlane is ignoring the cplane you define, and then you can’t get it to go back to world top.

I forgot to include the macro.

~_CPlane _Object Pause Enter
~_SetRedrawOff
~-NamedCPlane _Save TempTop Enter
~_CPlane _3Point 0,0 0,-1 0,0,1 Enter
~-NamedCPlane _Save TempLeft Enter
~_CPlane _3Point 0,0 0,0,-1 0,1 Enter
~-NamedCPlane _Save TempFront Enter
~_SetActiveViewport Perspective
~-NamedCPlane _Restore TempTop Enter
~_SetActiveViewport Top
~-NamedCPlane _Restore TempTop Enter
~_SetView _CPlane Top
~_SetActiveViewport Front
~-NamedCPlane _Restore TempFront Enter
~_SetView _CPlane Top
~_SetActiveViewport Left
~-NamedCPlane _Restore TempLeft Enter
~_SetView _CPlane Top
~_SetActiveViewport Perspective
~_SetRedrawOn
_ProjectOsnap Enable

This resets back to world:

~_SetRedrawOff
~_SetActiveViewport Perspective
~_CPlane _World Top
~_SetActiveViewport Top
~_CPlane _World Top
~_SetView _World Top
~_SetActiveViewport Front
~_CPlane _World Front
~_SetView _World Front
~_SetActiveViewport Left
~_CPlane _World Left
~_SetView _World Left
~_SetRedrawOn