OneView display glitch in Rhino 7

When I use the OneView mode and I tilt the view in such a way that it is almost parallel to a construction plane, the viewport rapidly jumps between two similar views. It is such a nuisance that I never use the OneView mode. I believe that there should be small delay before the viewport jumps to a different view.

have you tried increasing the angle? it will then jump earlier, or reducing it to make it jump later…

This problem seems to be intermittent. I always had the angle set to 44. Today I set OneView on, I set the angle at 44 degrees and later at 30 degrees, and tumbled the view. There was no difference - if I tumbled the view for about 10 seconds, I got into a spot where small movements of the mouse produced huge rotation of the view and the flickering, jumping effect. My mouse was clean.

I imported all options from Rhino 6, but, somehow, rotate view option was not imported. When I ran these tests, the rotate option was set to ‘Rotate around CPlane Z-axis’ - as shown in the following screenshot. I always preferred ‘Rotate relative to view’ so I changed it to ‘Rotate relative to view’. Good news - after the change the bug disappeared. :smiley:

Rhino7 OneView tumbling bug

1 Like

10 degrees is the default, I find that is it is a pretty good starting place.

you also know that ctrl+shift, while rotating close to an orthographic view snaps to that ortho view, and ctrl+shift+rotate pops back to a perspective view, correct?

Just want to make sure you are not missing that functionality, cuz it’s kinda awesome.
I’m mildly biased, since the dev name for this tool used to be “kyle mode”


Yes, I know it.

I know it as well and I am surprised that you do not use it in your tutorials. By the way, I love almost all your tutorials, but I have to stop them frequently to see which command you are using.

Yeah, that’s a really great feature… Exept that it’s not working properly in V7… See here