One shot on Crv disables SmartTrack

I am needing to place a point on a curve (B) so as to extend a Curve (A) to that point using F10 control points etc…

see attached.

I select point then oneshotonCrv from depressing ctrl over osnaps. the smartrack from the tip of Curve A ceases now to work.

I want to be sure the point is on curve B so need to use OneShotOnCrv along with smartrack as there are other objects around (not in the extract attached) that I could end up placing the point on.

If I try again without using one shot on crv, the smart track works.

Should the commands available with ctrl over osnaps disable Smartrack ?

OneShotOnCrv_disablesSmarttrack.3dm (27.7 KB)


I’m not following.
If I Zoom in to the perspective view, you B curve is swooping right on by the A curve.