One day sun animation - technical viewport

I had to do a sun study a while ago and I managed to make the one day sun animation using a custom technical viewport that I created especially for this. Now I had to revisit the project and make the same sun study on an updated design and it will just not work anymore. The render animation will either always switch to the default rendered viewport, or attempt to start a renderer (vray or rhinorender). I tried all options - RenderFull RenderPreview RenderedViewport Raytraced. There is no way to get the animation frames to stay in the Technicall view. I’m not sure if something got patched or if I got super lucky with unknowingly exploiting a bug last time, but that workflow does not seem possible anymore.

Another weird thing is if I open one of my old files and just hit record animation, it will run in the techical viewport and output frames with that viewport display as I initially intended. But as soon as i try and run the SetOneDay sun animation command again ( to change the day or anything), it will always swap to rendered viewport. abd i have not found a way to get it to output technical again after that.

Sounds like you need to send the old file to McNeel so they can see what’s going on. What version of Rhino are you using? Did you make the old file with a different version?

Hi Andrei - as far as I can see there is only a limited set of modes accommodated for the sun-study:

-Pascal

Yes, those are the options. Tried all of them, but can no longer get the technical view animation unless i record animation right after opening the old file, without running the set one day sun animation command. Once i run that command, no matter what option i use, i cant get it to save techical view. A month ago when i did the initial study, the rendered viewport option would just animate whatever viewport settings i had active. But now it always forces the default rendered viewport when doing the animation.

Hey,
Im using the latest rhino 6 version now. The initial file is about 5 weeks old. And the rhino version wss pretty recent also. Maybe 2.patches behind, no way to actually know for sure now but i gemerally try and update pretty often. Do you have any idea what the intended functionality is here? Is it supposed to work in with any viewport settings or just rendered view?

I don’t use sun studies (OK - once quite a while ago), so I’m not your guy. It just seemed obvious to me that what you describe couldn’t possibly be intended behavior.

A little update on this. Managed to hack my way into the desired result. I made a macro to set viewport to Technical2, and I click it right after it starts recording the animation. Then every frame is saved with the desired view settings.( it only seems to try and change the viewsettings to the standard rendered option in the start of the command).
Something is definitely weird about how the record animation command is written, since I can’t really manage to get it to work together with the SetDisplayMode part in a macro, but rather I had to make a separate button to hit, while the command is actually running. This does change the viewport settings mid animation, which I found impossible to do using a single macro.
Can some one at McNeel delete the part of the code that forces view settings on you when running this command. It makes no sense whatsoever. Thanks!

@rajaa - shouldn’t the sun study animation support any display mode for which shadows can be turned on? It seems to be limited to rendered variations & raytraced.

-Pascal

@pascal I believe that these were the only 2 modes that supported shadows when AnimationTools was written. Feel free to file a wish to extend it.

Hi Rajaa, - yep, OK, done

https://mcneel.myjetbrains.com/youtrack/issue/RH-49948

thanks,
-Pascal

1 Like

I ran into this before as well. While not a perfect solution, here is a similar example that I used to work around this issue. It does require plug-ins for Grasshopper.

Hey Chris,
Took a quick look at your example, and while you managed to get your Hanley3 display settings as an option in the SetOneDaySunAnimation window, that does not work for me. So I cant really choose it in a conventional way, but had to workaround the hardcoded presets with a macro that I have to run right after. The Grasshopper part was interesting though.