Offset surface problems

Hello, i am new to Rhino and am wondering how i go about thickening models that have geometries such as this model. I have tried offset surface multiple ways but nothing creates a enclosed surface. There are no naked edges on the model, and even when blend all edges it still produces a failed offset. i am wanting to offset the model by 2mm. I have no idea how to go about this, any advice would be appreciated.
-Thank you.

model.3dm (304.3 KB)

Hello Mattmcgowan29,

Try the command: _OffsetSrf and I think you will get what you want. ( It’s in the Surface Tools)

Thank you,


model 1.3dm (1.3 MB)

Works nicely.3dm (2.3 MB)

1 Like

Hi, could you explain how you did this please?

I think in “Works nicely.3dm” he used the shell-command on the middle-model. Not sure.


  1. I extracted the main top and bottom surfaces, used “Untrim” and repositioned their seam with the “Adjust closed surface seam” tool. Then I trimmed them again with the rest surface.

  2. I replaced both upper “channel” surfaces with a single one using “Sweep 2 rail”. “Blend surface” with degree 0 also may be used as an alternative.

  3. I drew two curves that describe cutting profiles close to the original shape of your 3d model. Then I copied them to the other side and used “Loft” to create cutting surfaces at the top and bottom. They have “History” enabled to be fine tuned if necessary. The top and bottom cutting surfaces give far better shape definition that the 90-degree wall thickness made with the regular “Offset” command that creates lots of self-intersections. If you often create models like this, I recommend making them slightly longer so that you can split them with similar smooth surfaces.

  4. I trimmed everything and joined together. That’s the 2nd model which I moved 200 units away from the original location. The top

  5. Then I used “Shell”, but there was a warning that Rhino failed to make it a closed solid model. I was unable to find a fully automatic way to make the thick model, so I had to untrim, extend and re-trim some surfaces to make it work. That’s the third model, which is 400 units from the original model.

1 Like

Thanks very much, this helped alot!