"Offset Crv" whit option soft vertex: inset is not executed. Why?

When offsetting a pentagon, for example, with the “soft”, “rounded” or “beveled” vertex option, why are these options not respected if you perform an inset?
(for offset it works, inset no).

can you post a screen shot with steps to reproduce?

From this command I would expect these solutions:

  1. The pentagon offset with the “rounded” option; and this is correct.
  2. This is the reverse offset (inset) with the “rounded” option; rounding is not performed in the corners.
  3. This is the result that should be generated.

The same example for the “bevel” and “soft” option. Could this operation make sense?

In the case of a star shape is more complex.
I understood the logic of the command … but also the last solution with “round” option could be valid, or not? (where possible).
In the latter case all the edges are rounded (could this be an additional option within the command?).
I’m trying to reason … Could a further “all edges” beveled or rounded option make sense?

This solution may also make sense (rounding for all edges):

yep- I see it now… this is a bit dodgy…

I’ll write it up-