Offset Bug?


The offset tool is trim the curves that is interpects on same polyline line

This is a Bug?

I tried to look for similar problem here in the forum and I didn’t find


I believe that is how the offset tool is designed to work.
Self-intersection polycurves act like you have shown.

If you need something different, you’ll need to eliminate the self-intersection and Join up the results after.
Another way is to set the command Trim option to None and do it manually after.

@John_Brock Thank you,

Sorry but I don’t understand what you mean by “eliminate the self-intersection”?


Explode the polycurve and offset each piece individually.

Thought there might be a faster way without exploding :sweat_smile:


Hello- the command has the command line option Trim=Yes/No.


I would swear I’ve seen it somewhere, but I can’t find it.

1 Like


My offset doesn’t contain these options, but I’m sure I’ve seen it here

Thank you.

I found, this option is only available on rhino7, I was with rhino6 and it doesn’t have this option.

you can always use curve boolean to create a curve from the insides of a self intersecting curve