ODD: Surfaces that rendered suddenly will not?


#1

The enclosed file shows two small surfaces that previously rendered in Shaded mode. I did a nearby trim and these two surfaces will no longer Shade (but all others in the area still do), but now display in Wireframe, no matter what display mode is selected.

I copied them into a new file in v508 and the same result occurred. I then rebuilt them and they shaded just fine.

Thought this might be of interest.

~Dave

Shading_Error.3dm (86.7 KB)

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-04-01 (508)
OS X version: Version 10.7.5 (Build 11G63)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro8,3
Processor: Intel Core i7-2860QM CPU @ 2.50GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6770M 1024 MB
Memory: 1024 MB
Screen size: 1920 x 1200, 1920 x 1200
Displays: Cinema HD, Color LCD

Third party kernel extensions
com.Logitech.Control Center.HID Driver (3.6.0)
com.Logitech.Unifying.HID Driver (1.2.0)
com.parallels.kext.prl_usb_connect (7.0 15107.796624)
com.parallels.kext.prl_hypervisor (7.0 15107.796624)
com.parallels.kext.prl_hid_hook (7.0 15107.796624)
com.parallels.kext.prl_netbridge (7.0 15107.796624)
com.parallels.kext.prl_vnic (7.0 15107.796624)

USB devices
Logitech: USB Receiver
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: iPhone
Apple Computer, Inc.: IR Receiver

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-7.32.12
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#2

.
try _RefreshShade …i’m not sure why it happens but i do have to use that command on occasion.


#3

Hmmmm…… No dice.


#4

@jeff_hammond: Did you happen to try RefreshShade on my file on your end? (Just wondering if it’s my laptop).

~Dave


#5

yeah… here it is after refreshing.

Shading_Error_refreshed.3dm (81.4 KB)

it does show up as you’re describing in the original post upon first opening it… (or- i don’t think you’re seeing the error because of your hardware. it appears as if the error is in the file itself… as far as why _refreshShade isn’t working for you, i’m not sure)


#6

Hmmmm…. Thanks for checking this, Jeff.