Octopus crashes when used in Grasshopper via Rhino.Inside Revit

Dear All,

I have a problem with the Rhino.Inside Revit Plugin. I am using Octopus plugin for the optimization and it crashes when used through the Rhino.Inside.

I tried to run Octopus in Rhino/GH (without passing through the Rhino.Inside Revit) and it works.

In Rhino.Inside Revit, when I double-click on the Octopus component, I get this message:

Do you know if it is Rhino.Inside Revit bug? Is it possible to fix it somehow? Did you encounter a similar problem?

Many thanks for your support!

Best regards,


1 Like

Looking at the octopus food4rhino it was last updated in 2018 and intended for Rhino 6, as well as numerous reports of conflicts with other plugins.

RiR doesn’t use the HelixToolkit WPF library, you could check for a conflict with a Revit Add-in.

What data type are you analyzing? Perhaps send it out to a non-Revit instance of Grasshopper with GHdata?

ghdata RiR Brep out



this is probably off-topic but oh my goodness had no idea we could do this?! just attempted and almost fell off my chair. this is incredible hahaha – can’t wait to deploy it!

Have a great week ahead!

1 Like

Hi Japhy,

thank you for your suggestions!

I tried to delete from GH Library folder all plugins that use HelixToolkit WPF library or are in conflict with Octopus (Wallacei, Human UI), but it still doesn’t work. I used also this Stantec Addin Manager to find conflicts in Revit (I disabled all plugins) and it doesn’t work. Maybe the problem is that Octopus is not updated for the last Rhino and Rhino.Inside Revit version.

I have no idea how to fix it :frowning:

Anyway, I imported geometry from Revit, then I baked it and used the script with Honeybee simulation directly in Rhino. There, I can open Octopus and run it. It’s not the best solution, but it works.

I will integrate your approach with Data Input/Output to smooth the workflow.

Many thanks!

Best regards,


1 Like