Objects don't persist/remain

Greetings. This is my first time using Rhino and from what I see I think I would enjoy working with it, but…

Whenever I draw an object, it disappears. For instance, I can draw a circle and pick the center point and a radius point and the circle draws, but when I click to finish the circle, it disappears.

Same thing goes with making a basic box: I pick the starting and stopping corners (left click on each point) and then pick the height, but as soon as I (left) click to finish, it disappears.

This happens with everything I draw. I’m on an evaluation license right now so I don’t know if this is what it’s supposed to do, but I kind of doubt it. How am I supposed to evaluate when I can’t draw persistent objects?

The software is a new, clean installation, if that matters.

I’m wondering if anyone else has encountered something like this and what you may have done to fix it.

Thanks for your attention.

Hi Dale!
Welcome!

Please run the command _SystemInfo and copy the result here.

Thank you for the quick reply. I believe this is what you asked for. I took a gander at it, but I’m not getting much from it:

Rhino 7 SR32 2023-8-9 (Rhino 7, 7.32.23221.10241, Git hash:master @ 3d9c816c4cd57561d12d8f53246bce304f314ba2)
License type: Evaluation, build 2023-08-09
License details: Cloud Zoo
Expires on: 2023-11-18

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon™ RX 560 Series (AMD) Memory: 4GB, Driver date: 6-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context 23.7.1.230626

Accelerated graphics device with 6 adapter port(s)

  • Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 6-26-2023
Driver Version: 31.0.21001.45002
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4074 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Does this happens even on a new empty file?
If that happens only on a specific file, maybe you have a clipping plane object active?

If it’s happening in any file, maybe try to lower your openGL version and/or disable GPU tesselation:


everytime you change one of this ^ settings, please restart rhino.

Hi @Dale_Schmitz
Just to add to @maje90’s comments, the AMD drivers are notorious for their bad OpenGL (which is what is used to draw the objects in Rhino on screen), so it’s not your (or McNeel’s) fault. First try turning off just the GPU tesselation, and if that isn’t enough, move the OpenGL level slider down one notch at a time, restart Rhino and try again. Hopefully that’ll get you sorted :slight_smile:
-Jakob

To answer maje90’s question, it happens on any file. I’ll try your and Normand’s suggestion and let you know what happens.

Thanks

And there we have it:

It only took unchecking GPU Tesselation. Thanks very much to the both of you. I’m not versed in graphics terminology and never would have thought to look here for my answer.

2 Likes