Objects displayed with simplified geometry

Rounded objects are being simplified when displayed in the viewport. It has happened frequently over the past few weeks and is extremely annoying. Once it happens, I have to go back and create the object again, but must be certain said object is visible in 3D view while I extrude it.

Hello- the ‘technical’ based display modes like Techical, Pen, Artistic, rely on the display meshes - you can goose the document display mesh settings to get a cleaner approximation- DocumentProperties > Mesh page, or object Properties > Custom mesh for individual objects.
File > Settings on mac.

More info here
https://wiki.mcneel.com/rhino/meshfaq

-Pascal