Object transparency totally screwed up

This is really driving me crazy, for no apparent reason objects in the shaded and rendered display modes are displaying as if the normals have been inverted, with surface edges showing through objects that should be opaque. Resetting view settings to default does nothing. The only thing I can think of that has changed about my PC is I just updated AMD catalyst to the newest version. I’m running 8.1 professional x64, 8 gbs of RAM and a radeon HD6900 series GPU. This has rendered Rhino completely unuseable for me as any model is now just a mess of lines whatever the view mode. Google has only revealed 1 other person who has had this problem from 3 years ago, and they never had an answer.

Someone please tell em they’ve experienced this issue, Rhino is critical to our business and right now we have to rely on our laptops which don’t have this issue and I really can’t afford the time to do a complete windows reinstall right now!

Sometimes this happens to me aswell. Just randomly.
Most of the times it is solved when I restart Rhino. If I then CageEdit the object. This problem wil return.

This has just been reported in another thread yesterday…


A week ago, as a gift for myself, I purchased a Gigabyte Radeon R7 250X, 2 G’s of GDDR5, seemed like the right thing to do. I too spent all of last night trying to figure out what I had done wrong. I didn’t want to ask, lest it be that I forgot to check a box or something. My computer had been crashing. since I installed the card also, only during Rhino. I have not had this problem with Rhino so i knew it was the card or the Catalyst software. The model would be see through and it has many facets, it was impossible to work with. When I got the card I installed the Catalyst package that came with it, which immediately says it is outdated, needs to be up graded, and at the end of that, says there is one more up date. I tried every combination of that software, so I finally just removed all of it from my computer. I make (put together) my own computers, so there is no one to call.

Lo and behold, Rhino is running fantastic, and this model which is 90% done, and completely unfolds, will be ready for my forum soon!

I don’t know the consequences of not running the AMD/ATI software, but so far, there seems to be none. I uploaded the picture as a screen shot for info purposes. Stealthstar from Battlestar Galactica. Not sure what to do next, to be honest.


The first thing I would try is rolling back to the previous display driver…

This one is important: Are you using the latest SR10 RC or are you still on SR9?

We’re starting to see/hear issues coming in similar to yours, but so far I’m having a hard time determining if it’s due to changes I’ve made or because of something AMD has done inside their driver (or both).


Hi Zathros,

Can you please post a screenshot of your Rhino’s OpenGL settings page… From the sounds of it, you’re probably using the WHQL drivers that Windows installs automatically (which happens when you uninstall a driver and then reboot…Windows attempts to figure out which drivers need installing and then does so). And if the drivers were installed at a previous date, then it happens rather quickly.


I hope this is the page you want. I am not to good at this stuff. If not, please give me “Idiot Instructions”. The machine locked up again, this time I did a system restore back be before that card, and a “Critical” windows update was done. I’m sure that will make it’s way back in. It is working well now. You may noticed, right now, I have the “Open GL” box “Unticked”. I am open to any advice. :smile:

Also, this was a “New” graphics card install, a Gigabyte Radeon R7 260C, with 2 Gigs of GDDR5 video ram.

Also, I am on the SR9 Candidate.


That’s the pic I wanted… However, you’ve said two things that have confused me…

  1. I have the “Open GL” box unticked… If you’re referring to the “Do not use OpenGL for drawing feeback” option, then that is supposed to be unchecked…so you’re good there. I agree the wording on that option is confusing at best…but you want to be using OpenGL at all times. The options in that page are really for diagnosing problems not solving them. So whatever Rhino sets them to initially is usually what you want to be using…and in your case everything looks good.

  2. I am on the SR9 “Candidate” ??? There is no such thing… Do you mean SR10? If you’re using SR10 then this is very important to know since we’re hearing other complaints in this area… I was hoping you were using SR9 and that rolling back the driver is all that is needed…but if you are using SR10 RC, then we really need to know that.


It reads on that page, “Version 5 SR9 64-bit”, in the description?

Ok phew… you are using SR9… That’s not a “candidate”…it’s just Service Release 9 …basically it’s the latest version of Rhino. … Soon it will be SR10, but not until everything has been confirmed to be working…until then, all SR10 releases are considered “candidates” for release.


So everything is fine? Do you I suggest I try putting a “check” the Open GL box, as normally, I do have that checked. :smile:

The Gigabyte RADEON R7 260X has been trashed this week all over the net for locking up computers. I just got an RMA for it ( Love Tigerdirect.com, you can speak to someone, always) and I am getting an XFX Radeon Double D R9 270X Video Card - 2GB DDR5, PCI-Express 3.0 (x16). I’ve had better luck with computers I build using XFX. Fingers crossed! :smile .Open GL “checked” or not, made absolutely no difference. i do not believe the problem was or is in Rhino, in my case. I think ATI/AMD has a problem with the Latest Catalyst driver concerning that chip series.


Well just after posting this topic I tried using the rollback driver option for my GPU, and Rhino started working fine again. Since then, I also had to do a reinstall of Windows and interestingly now I’m running 8 rather than 8.1 and Rhino’s still fine even with the up to date AMD drivers, so make of that what you will.

I kind of wonder if this had to do with a recent Windows Update. I am back on my old 1G Visiontek Radeon card, and it is running beautifully. Frankly, this new card I ordered is starting to make me wonder why i purchased another card? if this R9 gives me problems, i really won’t know what too do. Different manufacturer (XFX), Catalyst Drivers though. I don’t think you should have to do a full reinstall of Windows or roll back any service packs to have something work. My two cents worth.


The reinstall was due to Adobe Creative Cloud crashing right after loading and none of the online fixes working so yeah, none too impressed with Adobe, AMD or Microsoft on that one.

I have received, and installed my Visiontek R9 270X, with the driers that came with it, and it said they were up to date when it checked. Rhino is running excellent. I think this is a bit more complicated and has to do with card manufacturers stuffing old GPU’s into new cards, and not applying the Catalyst problems properly. i think there will be a lot of this until the old stock of GPU’s are sold off. In any event, for me, the issue is settled, and since Rhino is what I primarily need good graphics for, I’m all set. Thanks all. :slight_smile: