Object snaps in perspective


#1

Since last WIP (6.0.17164.11481, 2017-06-13) (or maybe before), I can snap objects in plan view but not in perspective view. To snap an object in perspective view, I have to select it before.
“Only snap to selected objects” is unchecked.


(John Brock) #2

So far I can not duplicate your description.
I drew polylines and circles and can easily latch onto endpoints and centers.

What specifically are you doing differently?
Perhaps a small sample file would help.


#3

I can not reproduce with new files. When I export one object of the file, I am still not able to reproduce the snap problem. I will give you access to my file in PM.


(John Brock) #4

OK, thanks.
Please be specific about what it takes to duplicate the problem.


#5

Try to trace a line in the perspective view starting from an angle of the selected object. It will work.
Now, unselect the object and try to trace a line from an angle of this object.


(John Brock) #6

Strange.
Only objects on the “bois” layer act that way and only when in a Shaded. Rendered, or X-Ray display mode.

If you switch to Wireframe or Ghosted, it works.
Also, objects on other layers like “plancher poteau” do work with osnaps in those display modes.

If I run ClearAllMeshes and switch back to a Shaded display, osnaps work again.
Did you recently move your model back close to the World coordinate origin?


#7

Thanks for your feedback. I have run now ClearAllMeshes and osnaps works again.
I don’t understand your question : [quote=“John_Brock, post:6, topic:45009”]
Did you recently move your model back close to the World coordinate origin?
[/quote] My model did not moved a lot. Objects still remained at less of 20000mm from the origin.


(Vanessa Steeg) #8

Thanks Alan! These problems often arrive when models are moved far or back from the origin. This answers our question.

Cheers