Object reference not set to an instance of an object

I had rhino6 on before, and was working just fine. I opened it today and it shows this and I can’ even use it. So, I uninstall it completely and reinstall it. and the same thing happened

Does Rhino start in Safe Mode? There’s a shortcut for Safe Mode in the start menu.

If so, please disable any third-party plug-ins in Tools > Options > Plug-ins and see if Rhino will start normally.

There have been many reports of Rhino getting messed up overnight on this forum and a frequent cause seems to be an automatic Windows 10 update which puts it’s own idea of drivers on the machine instead of the ones you know work. Something to consider.

no, it doesn’t. After I double clicks the rhino6 to open it, then 2 seconds with all the templates options and then it disappeared and small window come up “Object reference not set to an instance of an object” and I can’t run Rhino 6 at all”. I have window 10 eduction 1709 as bootcamp on my MacBook pro

I have window 10 eduction 1709 as bootcamp on my MacBook pro. but is there any solution to this problem?

Hi @Zbond6,

The next thing to try is enabling debug logging and sending the debug log. This will help us see where Rhino is failing to start:

  1. From the Windows Start menu, type Regedit then press Enter
  2. Browse to HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0\Global Options\Debug Logging
  3. Double-click Enabled and change the value to 1
  4. Double-click SaveToFile and change the value to 1
  5. Start Rhino
  6. Send the file RhinoDebugMessages from My Documents to us.

I hope this helps us figure out what’s going wrong.

Hi Brian,

I am getting the same issue.

-Installed rhino 6
-zoo licensing comes up

  • Login
    and then straight to
    “Object reference not set to an instance of an object”


Same problem here. I’ve uninstalled/reinstalled and updated to newest release. Any ideas?

@Zbond6, @slow88lx, @bruce.blundell:
If any of you follow the steps above and send me the RhinoDebugMessages.txt file, perhaps I’ll be able to help fix the problem.

Hi @brian

I also just installed Rhino 6. Tried to use CloudZoo.
I get the same error message.
Here’s the error log:

Windows version information:
	Windows 10.0 SR0.0 or greater, 64-bit, platform 0, version 10.0 build 0 sp 0.0, suite 0, product type 0

Rhino information:
	Build Date: 2018-11-07

11:50:25	BEGIN: CRhinoApp::InitInstance()	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6088]	Command: [none]
11:50:25	Initialize OLE libraries	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6096]	Command: [none]
11:50:25	Enable support for containment of OLE controls	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6107]	Command: [none]
11:50:25	Enable MFC 2.0 RichEdit Controls	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6122]	Command: [none]
11:50:25	Check to see if scheme name passed to command line	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6126]	Command: [none]
11:50:25	Set profile name	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6134]	Command: [none]
11:50:25	Load standard INI file options (including MRU)	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6140]	Command: [none]
11:50:25	Create string table collection	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6163]	Command: [none]
11:50:25	Create command manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6175]	Command: [none]
11:50:25	Parse command line	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6180]	Command: [none]
11:50:26	Load app settings	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6216]	Command: [none]
11:50:26	Begin InitWGLExtensions	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 673]	Command: [none]
11:50:26	Creating temp GL context window	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 710]	Command: [none]
11:50:27	ChoosePixelFormat	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 744]	Command: [none]
11:50:27	Successfully set pixel format	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 798]	Command: [none]
11:50:27	Successfully create GL context	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 819]	Command: [none]
11:50:27	Successfully enabled GL context	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 837]	Command: [none]
11:50:27	Set current video vendor string	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 901]	Command: [none]
11:50:27	Delete temp GL context	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 915]	Command: [none]
11:50:27	End InitWGLExtensions	[d:\buildagent\work\commercial\src4\rhino4\rhwglextensions.cpp line 940]	Command: [none]
11:50:27	Load the resources. This must happen after the profile is loaded	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6237]	Command: [none]
11:50:27	Initialize directory manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6243]	Command: [none]
11:50:27	Create event manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6259]	Command: [none]
11:50:27	Create license manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6281]	Command: [none]
11:50:27	CRmaLicense::SetLocale(1033)
	[d:\buildagent\work\commercial\src4\productlicensesystem\rmalicense\rmalicense.cpp line 151]	Command: [none]
11:50:27	Create splash window	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6311]	Command: [none]
11:50:27	Create MDI document template	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6323]	Command: [none]
11:50:27	Create CRhDocManager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6357]	Command: [none]
11:50:27	Add MDI document template	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6360]	Command: [none]
11:50:27	Create CMainFrame object	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6371]	Command: [none]
11:50:27	Load the CMainFrame	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6383]	Command: [none]
11:50:27	CMainFrame::PreCreateWindow Starting	[d:\buildagent\work\commercial\src4\rhino4\mainfrm.cpp line 1318]	Command: [none]
11:50:27	CMainFrame::PreCreateWindow returning TRUE	[d:\buildagent\work\commercial\src4\rhino4\mainfrm.cpp line 1419]	Command: [none]
11:50:27	CMainFrame::PreCreateWindow Starting	[d:\buildagent\work\commercial\src4\rhino4\mainfrm.cpp line 1318]	Command: [none]
11:50:27	CMainFrame::PreCreateWindow returning TRUE	[d:\buildagent\work\commercial\src4\rhino4\mainfrm.cpp line 1419]	Command: [none]
11:50:27	CMainFrame::OnCreate starting	[d:\buildagent\work\commercial\src4\rhino4\mainfrm.cpp line 1223]	Command: [none]
11:50:27	true  CreateRhinoDockBar(CCommandControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 647]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CRhZebraControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 653]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CCurvatureGraphControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 655]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CEdgeAnalysisControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 657]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CEmapControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 659]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CDraftAngleControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 661]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CThicknessAnalysisControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 663]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CCurvatureAnalysisControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 665]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CRhOsnapToolBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 670]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CRhSelectionFilterToolBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 682]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CContourAnalysisControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 685]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CEndAnalysisControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 688]	Command: [none]
11:50:28	true  CreateRhinoDockBar(CDirectionAnalysisControlBar)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 691]	Command: [none]
11:50:28	Skipping creation of CDragStrengthControlBar because debug logging is enabled	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 696]	Command: [none]
11:50:28	true  CRhinoTabbedDockBarDialog::Register(CRhinoNotesTab)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 723]	Command: [none]
11:50:28	true  CRhinoTabbedDockBarDialog::Register(CRhNamedViewManagerDlg)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 725]	Command: [none]
11:50:28	true  CRhinoTabbedDockBarDialog::Register(CRhDisplayAttrsDlg)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 739]	Command: [none]
11:50:28	true  CRhinoTabbedDockBarDialog::Register(CCommandContextDialog)	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 749]	Command: [none]
11:50:28	CRhinoAppUiDockBarManager::OnCReateDefaultDockBars returning 牴敵 	[d:\buildagent\work\commercial\src4\rhino4\rhuilib.cpp line 754]	Command: [none]
11:50:28	CMainFrame::OnCreate returning 0	[d:\buildagent\work\commercial\src4\rhino4\mainfrm.cpp line 1306]	Command: [none]
11:50:28	CRhinoApp::InitInstance() Event: (null) (1000)	[d:\buildagent\work\commercial\src4\rhino4\rhskin.cpp line 82]	Command: [none]
11:50:28	Create event message window	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6418]	Command: [none]
11:50:28	Initialize license manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 6422]	Command: [none]
11:50:28	Enable license checking	[d:\buildagent\work\commercial\src4\rhino4\rhinolicense.cpp line 884]	Command: [none]
11:50:28	Connection established with license manager	[d:\buildagent\work\commercial\src4\rhino4\rhinolicense.cpp line 914]	Command: [none]
11:50:28	Get license from license manager	[d:\buildagent\work\commercial\src4\rhino4\rhinolicense.cpp line 915]	Command: [none]
11:51:00	The license is not valid	[d:\buildagent\work\commercial\src4\rhino4\rhinolicense.cpp line 949]	Command: [none]
11:51:00	CRhinoUiDockBarManager::SetMainFrame failed m_main_frame set	[d:\buildagent\work\commercial\src4\rhino4\rhinouilib\rhinouidockbarmanager.cpp line 719]	Command: [none]
11:51:00	CRhinoApp::ExitInstance() beginning	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7666]	Command: [none]
11:51:00	Invalid mode: returning false	[d:\buildagent\work\commercial\src4\rhino4\rhinolicense.cpp line 1775]	Command: [none]
11:51:00	CRhinoApp::ExitInstance() calling SaveProfile()	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7713]	Command: [none]
11:51:00	CRhinoApp::ExitInstance() Saving plug-in profiles	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7749]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_lazyptr_texture_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7763]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_digitizer_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7770]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_license_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7778]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_rhino_plug_in_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7784]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_command_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7790]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_event_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7796]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_docview_manager	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7802]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() delete m_string_tables	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7808]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() CRhWGLExtensions::Shutdown	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7817]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() calling Gdiplus::GdiplusShutdown()	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7822]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() calling CWinApp::ExitInstance()	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7827]	Command: [none]
11:51:01	CRhinoApp::ExitInstance() exiting successfully	[d:\buildagent\work\commercial\src4\rhino4\rhino3.cpp line 7863]	Command: [none]

Do you have ETA for a fix? I haven’t been able to use Rhino 6 after buying it.

@brian @pascal

FYI I removed the license from the Cloud Zoo, then add the license again and it is working now.

@NKiD - Thanks for sending those details. I’m starting to see a pattern on computers that are really out of date from Windows’ point of view. Can you please verify that you have all the latest Windows Updates installed?

Also, if you open Rhino, then go to Tools > Options > Licenses, is that page visible, or blank?


The License page is visible.
I don’t have the latest Windows 10 Update. This is a work computer and the update has been disabled by admin.

I’m using it fine now, it’s all good :+1:


Hello Brian, I’m having the same issue as described by the others on this thread, I am running the latest updates for windows and tried uninstalling and re-installing to no avail.

here’s my Debug File

RhinoDebugMessages.txt (10.8 KB)

Here’s a new build of 6.11 that we hope fixes this startup problem:

Please report back here about how it worked for you.

1 Like

Hey Brian, I just installed the new build and it’s working with no issues, thankyou for the fix.


Hi Brian,

I just installed Rhino 7 & MKS Beam to export rhino object to revit.
But whenever i do the ‘‘Beam’’ option the below given message will pop up.
Please help me out on this…


That’s a problem with the BEAM Plug-in - you’ll need to work with those developers to fix this.

1 Like

I’m getting the same thing for the Enscape plugin…