OBJ roundtripping - RH6 bug


(Wim Dekeyser) #1

While testing overwriting imported obj files, I stumbled across this:


On the left, a pipe created in Rhino; on the right, that same pipe exported as NURBS obj and imported again.

RH6 file: Vertical Pipe.3dm (101.0 KB)

Results in RH5:
Importing that RH6 OBJ file into RH5 results in the blue surfaces in the middle, whereas roundtripping the green pipe in RH5 (export to obj and import again, all in RH5), results in the orange pipe on the right:

YouTrack: RH-44044


#2

Hi Wim,
while the error is obvious – do you know one single program which supports the Nurbs capability in the .obj format? Wavefront obj. is an old CGI format – pretty sure that Nurbs support is a rudiment from the early Nineties when Nurbs still played a role in film and special effects.

Solidworks and the likes don’t support .obj import anyway and the few CGI programs which still read basic Nurbs (3DSMax, Maya) do also import .step, iges etc. I’m pretty sure Tim could remove that legacy Nurbs option in .obj and nobody (besides Wim) would even realize :o)


(Wim Dekeyser) #3

If (1) it doesn’t work and, (2) nobody needs it, then your “could” in that sentence should be a “shall”. @tim

For the record, I don’t ever use OBJ - NURBS nor mesh - so I won’t notice its departure… :ø)
[I was merely testing the other issue that was posted here on discourse].

… & congrats on your new avatar, Holger - I didn’t recognize you in another topic yesterday (-;


(Tim Hemmelman) #4

OBJ nurbs surface writing and reading should work properly regardless. Who knows who might actually use it. Only a small fraction of Rhino users frequent the forum. It’s on my list to look at, but the fix probably won’t make it in until 6.3. This looks like a rational surface problem.

Tim


(Tim Hemmelman) #5

Thanks Wim for logging this on YouTrack.