NVIDIA denoiser not showing up bug?


I have an NVIDIA card and I’ve installed the denoiser through the package manager on Rhino 7. I cannot get it to show up in the post effects tab or in the render window.
Ironically, if I install the AMD denoiser using the exact same process, it appears everywhere. I cant use it, of course, as I have “no supporting devices”.
Please let me know if this is a bug or if I’m missing something in order to get it to show up.
Thank you very much!

Please post the text result of the Rhino command _SystemInfo.

Thanks Nathan,

Rhino 7 SR3 2021-2-22 (Rhino 7, 7.3.21053.23031, Git hash:master @ f8a40388712d9cf7edc68910e0415427bdefc64a)
License type: Commercial, build 2021-02-22
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-8-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Hmm, a P2000 should work with the Nvidia denoiser. @DavidEranen shouldn’t the pascal architecture be supported with the denoiser?

@j.burton you can always use the Intel denoiser though, that gives also excellent results.

I have the same problem with the Intel one. I can install but it won’t show up. Only the AMD denoiser shows up as a post effect… very weird. I have the latest Nvidia drivers I have installed and reinstalled all 3 denoisers several times and I have reinstalled Rhino 7. On settings, I have cycles set to CUDA. I can’t think of anything else. I have asked my work colleagues to try. They have the exact same hardware as me and it does work for them. I must have some setting wrong. any other ideas?
Thanks for the quick response, Nathan!

1 Like

That sounds rather peculiar.

Have you looked under Tools > Options > Plug-ins to see whether the denoiser plug-ins are loaded? If not try right-clicking each and select Load plug-in. Please pay attention to the command-line output while doing so. Any error message that appears there would be good to get a copy of in here.

Also check if a file called RhinoDotNetCrash.txt is created on your desktop around the time of trying to load the plug-ins. If there is please attach in a reply.

Maybe try figure out the differences in installed software? Maybe there is some antivirus blocking the plug-ins from running?

Yesterday I figured out through crashdumps that a user was using gaming overlays (i.e. Overwolf and the likes, also Discord) that made Rhino completely crash - maybe you have any utility software running that may interfere. Please check and disable anything you don’t need for Rhino work and see if that improves at all.

I uninstalled Discord - that is something I have that my colleagues don’t. Uninstalled the plugins. Reinstalled the plugins. They don’t event how up in the plugins list, but they do show up in the package manager as installed.
there is no RhinoDotNetCrash.txt. Rhino never crashes on me though, it’s just that the denoisers don’t appear to be anywhere.
Thanks again

Not sure what to suggest here. Maybe @DavidEranen has some ideas tomorrow.

I’m running an Nvidia Quadro P2000
I used the new PackageManager to install them.
Then they show up in the package manager:

I disabled my Intel GPU so I removed that Denoiser.
Now it shows in my Options > Plug-ins page:

And in Options > Cycles:

FYI, the Intel denoiser does not use the GPU. It is CPU only, so it should work on any machine.

1 Like

Hi @j.burton,

Can you try the following:

  1. Close Rhino.
  2. Go to C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins.
  3. Delete the IntelDenoiser, NVIDIADenoiser and AMDDenoiser folders if they are there.
  4. Start Rhino.
  5. Go to package manager and install the NVIDIA denoiser.
  6. Restart Rhino.

Do you now see the NVIDIADenoiser?


thanks again, everyone.
I have the exact same setting as John’s posted above.
It seems like the plugins aren’t in that address you said, Andrew. Does that tell you anything?
I am certain the plugins are installed through the package manager :slight_smile:

Hi @j.burton,

Let’s try this again, but now with another folder: C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\packages\7.0.

Please delete all denoiser folders from it. Then re-install the NVIDIA Denoiser. Then restart Rhino and test.


I found the folders in there! Deleted. Opened Rhino, installed Nvidia denoiser from the package manager. Closed out. Restarted Rhino and it’s there, but not showing up again…
Thanks David! Still no luck… :expressionless:

@j.burton Strange. Can you please try the following:

  1. Go to C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\packages\7.0 again, and go into the NVIDIADenoiser folder.
  2. Find the NVIDIADenoiser.Windows.rhp file.
  3. Click-and-drag the NVIDIADenoiser.Windows.rhp file onto Rhino 7, for example onto the viewport.

What happens? What text do you see in the command line? I have a feeling it will fail to load and Rhino will tell you why.