NURBS mesh facetted - smooth meshes/Flatshade off

Does anyone know why this happens?
Thanks H

Hi @hannesgrebin,

run _ShowEdges with the All Edges option enabled. If you see edges between the facets, the mesh may be not welded (requires _Weld)

Or is this a Nurbs surface which meshes facetted instead of smooth ?

_
c.

1 Like

@clement

As you see here, these are NURBS, how do you disable facetted display? Many thanks!

Hi @hannesgrebin,

if FlatShade is really OFF and the object is not very far from the origin, it would be best if you can post this object or parts of it.

_
c.

Hi Hannes - the display mode can have flat shading turned on, apart from the global setting in the viewport menu.
image
-Pascal

@clement @pascal Flatshade is off and also in Shaded Mode options. ty
Here is the file Doppelmayr.rar (6.9 MB)

image

@hannesgrebin, i can repeat what you see. It happens if the Shaded Display mode is set up as yours using ‚ÄúColor & Material usage‚ÄĚ set to ‚ÄúRendering Material‚ÄĚ. It seems to be related to the default lightning used in Shaded display mode. If switch to Rendered display mode it appears smooth without faceting. My guess is that if you switch the Lighting Method in the Shaded display to the same used in the Rendered display mode, it may cure it.

@pascal, if i enable FlatShade in the display settings of a displaymode then click OK, it does nothing in V5 and the checkbox does not stick :scream: If i enable the checkbox and then toggle another checkbox, eg. the one below, then OK, the setting sticks.

_
c.

Hi Clement -

It is not quite right here either but in a slightly different way - Options knows about changes in the Display panel, but not the other way round… Checking V6…
V6 gets it right.

-Pascal