Number of UNDOs is limited to just ONE

Hello, after opening an stp format file in my Rhino, I experienced that the number of UNDO prompts got suddently cut down to just one. No matter what the Options/General/Max memory used setting is, and it is more than sufficient here (4096MB).

What is even more unsettling, this limitation of undos available spread to my other Rhino files too and I cannot get rid of it.

Any idea please? Many thanks

What does Task Manager say about the amount of available system memory (RAM) when this happens?

Can you run SystemInfo in Rhino and copy/paste the results here?

Thanks. See attached. No matter how simple or large file it is, just one step back.


Well, first I would try downloading and installing the latest service release of V6 - 6.35. You are on 6.11.

https://www.rhino3d.com/download/archive/rhino-for-windows/6/latest/

If that doesn’t fix the problem, please report back here.

Understood. However, a colleague of mine running the latest Rhino 7 experienced the very same trouble.

Odd. In any case here in V7 I have dozens of undos. Also in V6. If you have one particular file that makes this happen, either post it here if it can be public, or send it in directly to tech at McNeel - Rhino - Rhino Support

in tools>options>advanced

search for undo, what do you have set here?

you can up the memory and set the min undos to something higher than 1.

The first of those is the same as the Max Memory Used setting on the General page, which the OP says he has set to 4096MB, four times the default value.

But what does the second one do?

Hi Jeremy - the second one sets a minimum number of Undos, regardless of allocated memory. This used to be in the top level UI but was too easily abused by setting the number to say 100 and then moving a gigantic mesh a few times , running the computer out of memory. Basically it serves no useful purpose that I know of and should be left at 1.

-Pascal

1 Like

That’s why this setting was actually removed from the main Options>General page as of V6. Didn’t know you could still access it from Advanced.

Nor did I…

-Pascal