Number input for transparency settings in display modes, changes to other value automatically


#1

Hi,

there seems to be a bug in some number inputs. I tried to change transparency settings for display mode ‘ghosted’ (under shading settings). when i entered a number 0-100 % or a float, the number input changed to a very high number (e.g. 1000000)


Rhino 6 for Mac WIP build 6.15.19071.17016
(Nathan 'jesterKing' Letwory) #2

Do you have Dutch setting for MacOS, along with comma for decimal separator?


(Nathan 'jesterKing' Letwory) #3

I see this happening here too. I logged a bug: https://mcneel.myjetbrains.com/youtrack/issue/RH-49254

I have Finnish as my region setting, which means I have also a comma as decimal separator.


#4

Hi Nathan,
thanks for checking. Indeed my mac uses comma separator as default. I tried comma separated numbers as well, but without the desired result.

cheers, tim


(Nathan 'jesterKing' Letwory) #5

I doubt that is going to work, there is probably a slight confusion code-wise how to deal with numbers when using ‘exotic’ settings. We’ve gone over most of them, but apparently some cases still exist.


(Nathan 'jesterKing' Letwory) #6

FWIW this will work in the next WIP. I just tested a fix for this problem.


(Dan Belcher) #7

This should be fixed in the latest RhinoWIP. Please give it a try.