Ntdll.dll error

Does anyone else experience Rhino 5 SR 12 crashing when saving (but also occuring randomly)?
Looking in the Windows event manager it states that there is a problem with “C:\WINDOWS\SYSTEM32\ntdll.dll”.
I did not found anything on the internet about this, but it is devastating, because you can’t save anything, and .bak files are not created.

Not sure if that dll belongs to Nvidia, it might though, and if you are having “random” crashes (not just during save) then it is most often a video driver problem…


Are you only getting problems with Rhino?
The NT Layer DLL contains Microsoft NT kernel functions and if that really is the cause of the problems you are having I would expect this to appear elsewhere as well.

As Mitch says, random crashes in Rhino tend to point at the video driver - run Rhino in safe mode and see if that crashes on save as well.

Is your version of Windows up-to-date? Virus scanning?
What is the ntdll.dll file?

Yes, Rhino is the only problematic program, as far I can see.
I’m on Windows 10 and up-to-date.

Do you get a crash report UI from Rhino/McNeel when these crashes occur? If so, please send those in. Also, you did not say if the video drivers are up to date - can you send a screen shot of Rhino Options > View > OpenGL page?


Hi Pascal,
sadly no. I don’t get any Rhino crash reports.

My video drivers are up-to-date, atleast Geforce Experience says so.
Here are the OpenGL settings.

Thanks - that does look like it’s the latest driver - odd that Rhino does not see the date though. I’m not sure what to suggest…

But, apart from the crash, .2dmbak files should be created every time you save a file (after the first save) and AutoSave can help as well - are those enabled? (Options > Files page)


Yes, they are on.
But the problem is the first save. I don’t get there. Rhino crashes before anything is saved.
Sometimes a restart of my system will help. If the first save did work it will do longer until I close Rhino.

(at first I thought, the ntdll would be defect. Tried sfc /scannow without luck)

Please try Rhino in Safe Mode - does that behave any better? are you running any non-default plug-ins? Can you just open Rhino, make a box and Save?


Luckily Rhino worked normally for now. If it happens again I will try the safe mode and report here.

Hi Pascal,
today the error occured again. Rhino in safe mode did work well.
I found out it was Maxwell causing the problem. Removed the loading of the Plugin.
Hopefully this will be fixed soon.

@jdhill - dunno if this is something you should hear about…


Unfortunately, I am aware of no such issue at this time, and so can’t say much with only this information to work with. Please make sure your plugin is up to date (download the current version 3.2.0 plugin, by logging into your account at https://portal.nextlimit.com), and write back to say whether it makes a difference.