Not able to cap

hi there,

back again with the basic questions.
built up this ring, can’t get it to cap. tried every surface tool and can’t seem to get it to work. it does show naked edges but no idea how to fix it. if anyone could take a look and help me out why/what i did wrong it would be a blessing. thanks.

ringicantcap.3dm (1.3 MB)

after further investigation, i see that i have a naked edge in the model. is there any way to fix this without having to start all the way over? thanks.

Another reason it has issues with capping the top part is due to the open edge not being planar.
“The Cap command fills openings in surfaces or polysurfaces with a planar surface joined to the hole edge.”


the top edge isn’t planar

and these surfaces are not matching:

if you fix that, explode the shape and use _SetPt z=yes on the top control points you can get it to work

i think i fixed the surfaces. only wondering now how to get the top edge planar. tried the _setpt but I don’t understand it. can you have a look?
ringcap.3dm (1.1 MB)

explode the shape, the turn on control points, select the top points like this, then run SetPt:

1 Like

i got it, thank you for the detailed explanation!

You have a complex surface with an even more complex edge. Not surprising! Here is how I avoid that situation entirely.

I call the strategy ‘Build it bigger, then trim back.’

In your case:

  • I would have built the outer surface taller than needed.
  • Now make a ‘cap / top surface’ which can be flat (or any other shape needed)
  • Make that surface also bigger than needed, so it passes through / intersects 100%
  • Split each surface to the other (A to B … and then … B to A)
  • As long as the two surface intersect, this is guaranteed to work.
  • And it does. Every time. I guarantee it.