No way to use Version 6

display

#1

Hello together,

I have the general problem that I’m simply unable to use version 6 on my computer.
I already complained about this some time ago. In between it looked to be solved and now I’m facing the same problem.
When I open the program, one of the windows comes up black. When I open a file all windows are either black or grey.
Version 5 runs perfectly?

Any idea?


The system is a Dell 6500, Win7 with an ATI FirePro M7820 graphic card.
Towards the standard answers…
Driver is a bit of a problem I know, but since any other program ever worked fine (and there where several cad programs among them in the past years) I can hardly imagine it’s the driver.


#2

How old is the driver?


#3

For me it looks like it using the embedded one.
of course a driver update could help.
try to force rhino 6 to use your ATI video card.
should be in the starting icon properties


(David Cockey) #4

This thread may be relevant, in particular posts by @jeff from post 44 onward: Rhino continues to crash [SOLVED] Apparently the way Dell preloads some of the their machines can keep the GPU from being used by Rhino 6.


#5

Hello Dan and Skysurfer

thanks for the quick reply.

The driver is latest from Dell which means 2014.

Fond out there is a “newer” version released by AMD in 2015. But since it’s not by Dell I’m insecure if I should install it.

If I understand you right skysurfer, Rhino is using the graphics card driver?

The viewport by the way, is in shaded mode.


(John Brock) #6

That all looks like the symptoms of inadequate OpenGL support to me.
You’re looking at updating the display drivers or replacing the display adapter.
Since the FirePRO is that old, I’d not be very inclined to spend any money on upgrades to a computer that old, but that’s me.


#7

Well John, I don’t really like to admit, but basically I came to that conclusion also.
But hope dies last, as we say round here.

It’s just a pity to give away such a fine piece of computer (still way better than most consumer crap) for such reasons.

So it looks like I could try the latest version of the driver and if it’s not turning out well, then its time for a new computer?


#8

But there is still the question why did Rhino manage in between?
To be more precise during the first releases of version 6?


(John Brock) #9

That I can’t explain.
Perhaps @stevebaer or @jeff might have ideas on that.
It’s possible we screwed up something as the service release fixes have come along.


(Steve Baer) #10

If this worked in previous releases of V6, we can get you links to those older builds.


(Jeff Lasor) #11

The driver looks like it’s from 2010, given the screenshot…that’s right when OpenGL 4.0 was released… my guess (and that’s all this is) is that AMD’s first implementation of 4.0 is buggy at best, and that newer versions of the driver may fix that. Since your drivers are reporting “4.0”, then that’s what Rhino V6 is going to use, buggy or not…there is no way for Rhino to know if a given GL implementation is good or bad, only what its version is. Rhino V5 only uses OpenGL 2.1 (and in some cases 3.0), which have been around way before 2010 (i.e. buggy drivers have had a chance to stabilize). I would install the very latest driver version you can get your hands on…and I wouldn’t depend on Dell to provide that…Dell is only concerned about the software that they pre-install on their products and not software that gets installed post-release. Which means, they’re only going to ensure that software released back in 2010 is going to work with whatever drivers they provide…Dell also tends to have a 5 year phase-out time-frame, and anything over 5 years old will most likely not get any update by Dell…even though most hardware OEMs and ODMs release drivers well over 5 years.

So the first thing I would do is update the drivers.
If that still doesn’t seem to work, then we can start trying some things that will “throttle back” V6, to see if running at a lower OpenGL level will work better.

Let us know…

Thanks,
-Jeff


#12

Thanks for the reply.
I’ll try the driver and let you know here about the results.
Think it will take time until tomorrow.

The throttle back version is not my fascination. In this case I’d rather go for a long therm solution.


(Jeff Lasor) #13

It wasn’t really meant as a solution… It will help us determine where and why V6 is failing on your config…so it was more a diagnostic step than a solution.

-J


#14

Well then, if I can help you we can try the previous releases. Let me know the locations. I’ll give it a try.


(Jeff Lasor) #15

The first thing that should be done is to update the drivers to the very latest version available. It would be pointless to try previous versions of Rhino if the problem(s) really resides inside the drivers. Previous versions of V6 may have worked simply because those versions hadn’t yet implemented GL specific features.

How low ago do you remember V6 working? If it was recent, then we probably broke something with an update…but if it was an early WIP version, then going back that far will probably not be very helpful.

But again, the first order of business would be to update the display drivers to the latest version you can find.

-J


(L Polski) #16

we had sometimes this black issue using rendered mode:
our solution was to change the lighting method to “no Lighting”

may be it helps you out?


#17

Hello together I’m back with latest news.

Made the driver update and yes things improved significantly.
The black windows are gone.
@Jeff to your question, can’t tell exactly the versions I remember working. Think either the latest WIPs or first release. Cause it was one of the reasons why I felt good to purchase.

Just had a brief look at the new situation. Way better but, doesn’t seem to run like, I think it should, but eventually we can figure out here why?
What I’m realizing now is switching between the modes shaded and wireframe doesn’t always show the part at once. Only if a part has been selected first it appears in the wireframe window like it should?
The rendering is strange too, it’s supposed to show wood but for some reason it looks like it does. It’s the same in my V5. But there it was working before and things looked like wood…

OpenGL section looks like

ATI Technologies Inc.
ATI FirePro M7820 (FireGL)
OpenGL-Version: 4.4.13096 Compatibility Profile Context FireGL 14.301.1019.0
Renderversion: 4.4
Schattierungssprache: 4.40
Treiberdatum: 1-24-2015
Treiberversion: 14.301.1019.0


(Pascal Golay) #18

Hi Martin - this is what catches my eye. Can you get a newer driver from ATI/AMD?

-Pascal


#19

Don’t think so.
The one I used is the latest offered by AMD.
To me it looks like, rare notebook with rare graphic card… who cares? No drivers at all for Win10…
That’s the reason why I tend to follow John’s advise, because I see more of this kind of problems with programs giving me hard time in the near future. Latest when I have to switch to Win10.

Else I’m not to deep into the topic of drivers that I know what kind might work.


#20

In my old Dell Precision T5400 tower, I had to switch my ATI card for a new Nvidia card. ATI’s OpenGL support was never the best, and apparently Rhino v6 tickled some bug that Rhino v5 did not.

Is there any possibility you can replace your graphics card with a newer NVIDIA card?