No UI for rendering

I’m trying to activate post effects in Rhino Render but get the message Post Effect has no UI??

Hi tgra, I see this is for Mac, can you type in SystemInfo to the command line and post the results here please? Thanks

Rhino 7 SR18 2022-5-25 (Rhino 7, 7.18.22145.08132, Git hash:master @ a2f70299f1d18c46806894c03a86e954fb7ab656)
License type: Commercial, build 2022-05-25
License details: Cloud Zoo

Apple macOS Version 12.4 (Build 21F79) (Physical RAM: 32Gb)
Mac Model Identifier: iMac18,3
Language: en-TH (MacOS default)

AMD Radeon Pro 580 OpenGL Engine (OpenGL ver:4.1 ATI-4.8.54)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB
Graphics: Radeon Pro 580
Displays: iMac (217dpi 2x)

Graphics processors
Radeon Pro 580 (8 GB)
iMac (2560 x 1440)

USB devices
Western Digital: My Passport 25E1
USB : Flash Disk
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Magic Keyboard with Numeric Keypad
Wacom Co.,Ltd.: Intuos5 touch M

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswift_Concurrency.dylib
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftCryptoTokenKit.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftCoreAudio.dylib
/usr/lib/swift/libswiftCoreML.dylib
/usr/lib/swift/libswiftCoreMedia.dylib
/usr/lib/swift/libswiftOSLog.dylib
/usr/lib/swift/libswiftVision.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftNetwork.dylib
/usr/lib/swift/libswiftDemangle.dylib
/usr/lib/swift/libswiftFileProvider.dylib
/usr/lib/swift/libswiftIntents.dylib
/usr/lib/swift/libswiftPrivate_BiomePubSub.dylib
/usr/lib/swift/libswiftPrivate_BiomeStreams.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftAVFoundation.dylib
/usr/lib/swift/libswiftCoreMIDI.dylib
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/SubstanceImporter/2.0.2/libSubstanceImporter.dylib
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/SubstanceImporter/2.0.2/libsubstance_ogl3_blend.1.dylib
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/SubstanceImporter/2.0.2/libsubstance_linker.1.dylib
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/libtbb.dylib
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/libtbbmalloc.dylib
/usr/lib/log/liblog_network.dylib
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/libOpenImageDenoise.1.2.3.dylib

Rhino plugins that do not ship with Rhino
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/SubstanceImporter/2.0.2/SubstanceImporter.rhp “SubstanceImporter” 2.0.2.0
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/AMDDenoiser/0.5.3/AMDDenoiser.Mac.rhp “AMDDenoiser.Mac” 1.0.0.0
/Users/tonygrainger/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/IntelDenoiser.Mac.rhp “IntelDenoiser.Mac” 1.0.0.0

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.18.22145.8132
/Applications/Rhino 7.app/Contents/PlugIns/RhinoBonusTools.rhp “Rhino Bonus Tools” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/PlugIns/SolidTools.rhp “SolidTools” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.18.22145.8132
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.18.22145.8132
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.18.22145.8132
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.18.22145.8132
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.18.22145.8132
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.18.22145.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.18.22145.1002

I’m not seeing similar reports. One thing of note is that my fairly default ‘Rhino plugins that ship with Rhino’ list is much larger. Can you a standard reinstall and see if that add anything (vs the complete uninstall and reinstall. Thanks.

Hi @tgra ,

The issue may be that the post effect chosen doesn’t have additional options other than being enabled or not. Which one are you trying to use? Post a screenshot please if you need more help.