No templates, no material library

After running into the viewport crash (Raytraced viewport size change causes crash) I lost Viewport > Raytraced (the command line would return Display mode set to “”).

I suspected corrupted user prefs so I tried a clean start by renaming my prefs (AppData\Roaming\McNeel\Rhinoceros\6.0)

Viewport > Raytraced is back but now I get no templates and no material library. AppData\Roaming\McNeel\Rhinoceros\6.0\Localization does not get created.

I tried to reinstall the latest WIP from scratch, reboot my comp and all, but that was of no help.

If you still have your old prefs folder you should copy that back in place, then try any of:

  1. Tools > Options > View > Display Modes . Check if there is an empty line that you can select. Also if you do see the Raytraced mode, select it. If you can select it, delete the mode (Raytraced or empty line). Restart Rhino WIP and see if that brings it back - it should, as the Raytraced mode is in a plug-in that is automagically loaded at start-up, and registers its own display mode if it can’t find it from the settings.

  2. If 1) doesn’t 'work only rename the Appdata\Roaming\McNeel\Rhinoceros\6.0\settings folder, then start Rhino WIP. The same automagic plug-in loading should register the display mode.

  3. Do a full reinstall by also cleaning your registery from all Rhino WIP related keys with regedit, then installing the WIP from scratch. Note that the regedit step needs to be done with absolute care, since wrongly editing your registry may cause your machine to not boot/function properly. If you delete just the McNeel\Rhinoceros\6.0 keys you should be fine.

/Nathan

  1. worked.

Thanks Nathan !

Happy it works again for you :slight_smile:

/Nathan