No tangent snapping with project osnap


#1

To _Rotate the earplug to lie flat on the ground, using End osnap, Tan osnap, and Project osnap, I first need to move the curves so that they lie in the x-z-plane. To figure this out took me a little, and I found it counterintuitive. But maybe that’s how it’s supposed to be…

earplug.3dm (49.6 KB)


(Pascal Golay) #2

Hi Felix - the whole opertation can be done in the Right view with End Osnap. Do you see that? In the Perspective view Rotate3d may help. Am I understanding your comments…?

-Pascal


#3

Not sure if you understand my comment @pascal. The operation can be done in the Front viewport by using _Rotate, but only with Project osnap turned off. I was expecting the operation to also work with Project osnap turned on.

The goal is to have the earplug lying flat, as if put on a table.


(Pascal Golay) #4

Hi Felix - if the goal is the green curve in my image, then Rotate in Right; if the goal is the red curve, then Rotate in Front, either way, projecting snaps should not matter - Rotate is a 2d operation… Am I still not getting it?

-Pascal


#5

Did you never put an earplug on a table? :wink:
Screenshot of front viewport


(Pascal Golay) #6

When I’m told to out my earplugs flat on a table I always put the flat side down. Otherwise they roll away every time and I get lint on them from the floor.

I guess the problem you’ve run into is that there is no tangent from the projected End to the curve itself - that point would have to be established first and then the point is projected. So yes, leave Project off since it is a 2d operation anyway…

-Pascal