No shadows with spotlight

When I place a spotlight it does not give any shadows and light goes through the objects in rendered view:

Hardware acceleration is checked. Any ideas?

Hi Mike- lights can have shadows turned down, or off, and objects can also have shadow casting turned off - check Properties for these- if you cannot sort it out, send the file…

For a rendered display mode, as opposed to a full rendering, it may depend upon the video support - what video card do you have?


Here is the file. This problem is for more then one computer so I do not think it is the issue with graphic card (I checked on three different machines with different cards). Restoring default settings do not help.

The other ones I think run on Nvidia quadro 4000.
spotlight bleed.3dm (293.9 KB)

Your driver is very old, I’d up date that but I see the problem here with your file as well… still poking.

If I rotate your light, it starts casting shadows…


True but it is a bigger problem. It bleeds in many more cases - vertical plane:
spotlight bleed.3dm (293.5 KB)
I have seen an example with non planar surface as well - stairs were illuminated through the wall. Cannot send this one though. Interestingly it renders fine.

Yeah, for sure it is not right… It is a bug.