No shadows on MacBook PRO retina with IRIS GPU

I use macbook pro with Iris pro GPU running Windows 8 as second boot (boot camped). I am not able to switch ON the shadows on rendered display mode. What can be wrong? Thank you.

Which SR are you using? I thought the latest SR had enabled support for this…

First, please make sure that “Use accelerated modes…” is CHECKed in Rhino’s OpenGL settings… IThen…

Try this:

  1. Start Rhino
  2. Run TestVendorGLSupport
  3. Make sure the command line reads “Intel=Yes” and enter out of the command.
  4. Load your model and see if shadows work now.

If they don’t, then please grab a screenshot of Rhino’s OpenGL settings page and post it.

Note: The TestVendorGLSupport is a test command and it is not remembered across Rhino sessions, so you will need to run it every time you start Rhino. Therefore, if this ended up working for you, then I suggest you place the following in Rhino’s “Startup command list”:

-_TestVendorGLSupport Intel=Yes enter

…this will cause the command to automatically run every time you start Rhino.

-Jeff

1 Like

I’m having the same problem getting shadows to render in VMWare, also on a MacBook Pro.

This is what I see when I run TestVendorGLSupport:

If I set VMWare=Yes, I get this odd dark rendering:

But running the command in either case doesn’t turn on shadows. These are my OpenGL settings:

Anyone have any advice how to get shadows to render? They render fine in Bootcamp.

Chris

Hi Chris.

Vmware unfortunately is not supported.
So things like this can be expected and have no official solution or fix.
http://wiki.mcneel.com/rhino/virtualmachines

-Willem

I know VMWare Fusion is not supported officially, but Jeff’s comment seemed to indicate that he thought shadows should work with the latest service release in place.

Chris

Nope, not the same thing.

Yes, shadows should work with the latest SR, but for native Windows ONLY. VMWare still has some serious issues for some of the more advanced OpenGL features, shadows being one of them. You’re lucky that you’re only seeing black results…in most cases, the entire VM shuts down and the OS has to be restarted.

Do not confuse things I say about Intel GPUs and bootcamp with VMWare… Bootcamp and VMWare are not the same thing. Bootcamp is really just a set of drivers that allow specific, proprietary devices on your Mac to run under native Windows. In fact, you don’t even need Bootcamp to run Windows on your Mac. You could completely throw out your Mac’s hard drive, replace it with a new one, and install Windows directly onto it without OSX, without Bootcamp, without anything from Apple. The only things that wouldn’t work would be things specific to your Mac (i.e. backlit keyboard, camera, etc…), but everything else will work and function just fine.

VMWare does not work that way… VMWare requires OSX and runs under OSX… It creates a virtual machine running under OSX, from which you can install and run another OS…like Windows…but that is still not the same thing as a natively running OS because there is still the layer between the VM and OSX that exists.

Hope that makes sense.
-Jeff

I see that I mis-read the original question the first time around. It was clearly referring to BootCamp and not VMware. Thanks nevertheless for the replies.

Chris

You can check your display driver version in Windows and compare it to the current Windows drivers Intel has for your graphics hardware.

If there are newer Intel Windows drivers give that a try - you’ll rollback if the results are negative.

Apple does not often update the BootCamp drivers they distribute. We saw an OpenGL display issue with Bootcamp distributed ATI drivers that were several years old. Newer ATI drivers, direct from ATI, solved the OpenGL issue. In this case ATI specifically lists “BootCamp” drivers for download. Don’t know if they are actually any different, however. Not sure if Intel does the same. Again, if a new driver blows things up, just revert to the semi-working Apple provided drivers.