No object showing in Shapediver

Hi! I have a very simple gh code that I have been trying to upload to shapediver. The upload is successful, but when I try to view the model (see link), no object is shown only the shapediver logo. What could be the issue causing this?

Link to shapediver model:

IslamicPattern(forShapeDiver) (22.6 KB)

I can’t look at the file right now, but did you include the geometry display component and have something connected to it? I think it also needs a material to work.

Additional info:
If I turn on preview for component “Merge” containing all of the lines, they show up when uploaded on shapediver. However, I tried turning on preview for every component after this one, starting with “offset” and those do not show up on shapediver. Thus, I think there is some issue coming from flattening the merge component or from offsetting lines.

@amelija.ancupane I reviewed the model. It’s not totally clear to me yet why the surfaces are not showing up. For now please try this:

  • Convert the surfaces to meshes
  • Use the “Mesh Brep” component and choose meshing settings such that the number of vertices/faces is as low as possible.

Thanks for the idea, but the mesh didn’t work either. I ended up going a different way and instead of offsetting the curves, I used the perp frame component and used the frame for the plane input in the rectangle component. Then lofted the rectangles and everything worked! I think the offset component seems to be the one causing some issues…

IslamicPattern(forShapeDiver) (15.4 KB)

You can also decrease number of rectangles and use our own LoftMesh and Display components for improved performance.

IslamicPattern(forShapeDiver) (37.4 KB)

More on best practices for publishing models on ShapeDiver in tutorials below.