No displacement from Quixel textures

I’m using quixel mixer to create textures but my displacement maps are not working in Rhino. I’m saving out of quixel as 32 bit exr files but get no displacement when I load them into Rhino. If I try a rhino texture like noise etc I do get displacement. One odd thing is I see the displacement in the rendering preview of the material but nothing in the viewport or rendering. I tried high mesh counts on a plane custom meshing and even triangulated meshing and still nothing.
I’ve tried tiff out of quixel mixer but also no results. They have many settings for displacement but which one works with Rhino?
Thanks for any help on this,

Hi RM - please post a simple file with a material using the texture that does not work.


Hi @pascal
It’s 34 meg one plane and textures, can I send it to you.
What’s your upload link?
Thanks for your incredible help,

as always, large files can be uploaded using Rhino - Upload to Support . Just make sure you copy the URL of this topic in the comments section so that the upload finds the correct people.

Hi Pascal, Nathan,
I uploaded the file please take a look and let me know what you find.

Hi RM - I was just resonding via email. The texture is an exr - if you make it a png then it will work. You also need to make sure that the object has a mesh which can be displaced with some detail - the plane has just one or two polys and displaces as a plane. The exr seems only to want to displace as a plane, it ignores the render mesh - not sure what is expected there but a png works. You may also want to clamp the output as the texture is all on the very light side, or make it a higher contrast like the attached.


PNGs and EXRs should work just alike, with the difference that EXR can hold more precise data - better gradients.

On my machine the EXR looks incorrect in the texture preview - I’d guess this is cause of the problem - @pascal if you could log that as a bug, I probably can have a look at the code next week when back.


Here the texture preview looks good with an exr , but a pbr with that texture for displacement does not, in Rendered mode -

It is correct when raytraced, here.

RH-66850 Display: PBR displacement incorrect in rendered mode


I was talking about the texture preview when you drill into the texture slot, as per my screenshot: the EXR shows completely white for me.

Ah, Ok - yes, the texture preview, - it looks correct in the texture panel at the top level but not inside the control.


I noticed the same. It may be very well related to why displacement doesn’t work well with the EXR. I tried even saving it as EXR with different codecs and as HDR. They all failed to work properly. Your PNG trick helped here.

Hi @nathanletwory @pascal
Thanks for taking a look so that means a bug exrs are not working?
I did try with a high res plane and even with a high res triangulated plane. I still think even with the save as png trick and a high res plane displacement is still not working properly the result in rhino doesn’t look like the result in quixel mixer. They also have other formats and bit depths etc for displacement it would be great to get the complete work flow working in Rhino. You at McNeel could download quixel for free that way we’d be on the same page and it might help with these bugs.

The source of the bug has been identified by @DavidEranen . I’m sure a fix will soon exist.


Nice Looking forward to the fix.
Thanks Nathan and Pascal for your help and work arounds.

1 Like