New WIP version S-L-O-W

Moving control points on a solid is suddenly excruciatingly slow. Moving 4 points in the new version exceeds 30 secs. in Rhino 5, less than 1


1 Like

It’s instantaneous in a test file in RH6 here.
Meaning: there must be something specific to your file, your system, or a combination thereof.
You’ll have to provide more information if you want anybody to be able to fix this.

I have experienced a similar performance problem with (at least) the last two WIP releases. Several weeks ago, I created a 2D view of a customer product using the make-2D drawing command. The result was a curve set consisting of 12193 elements. At the time I was able to transform the set without any noticeable delay. Today, using last week’s WIP, I attempted to move the set to a new location and it took five minutes (plus or minus one second) to perform the transformation.

I analyzed the set and all the curves were reported to be valid.

I exported the curves to a Rhino 5 format file and, using Rhino 5, was able to perform the same transformation in one or two seconds. To cover my bases, I opened the new rhino 5 file in the latest WIP (5/16/2017) and made the same transformation. Once again the WIP required five minutes to perform the operation.

I am not making any claims regarding the quality of the curves, I am merely calling attention to the difference in performance between Rhino 5 and the current WIP when performing a basic transformation of the same set of data.

1 Like

An example model would be very useful here, or a detailed description of how to reproduce.


I’ve been looking at this model that you sent me and am not seeing any delay with moving the group of curves. Are you using the Move command for this, the gumball, or some other technique?

I was editing solid points.

I will need a sample as I can’t repeat any sort of slowdown with solid point editing. Thanks


I have transformed the curves using the MOVE command, the Gumball, and
the NUDGE method (i.e. Arrow Keys), as well as ROTATE 3-D.

One additional behavior that initially accompanied the slow performance was
that whenever I was working in a single view (such as the perspective
view), the interface would change to four views while it was performing the
transformation and then return to the single view when the transformation
was complete. This is not happening in the latest WIP, but I am still
experiencing the slow performance with this particular set of curves. The
"preview" of the move is displayed instantly, then the "spinning circle"
appears and the application chugs away for several minutes while it
calculates the move. Incidentally, when I use the MOVE command, I define
the the move by snapping to two arbitrary points on the line beneath the
set of curves.

It may also be worth mentioning that the transformation is occurring a
little more quickly in the latest WIP than it was previously. It now takes
about three minutes, instead of five.

I hope this helps, but if you are not experiencing any performance issues,
the problem may be due to something specific to my setup.


Have you installed any custom plugins? I’m trying to see if there are any other possible players in this situation

Also, if you can send me a screenshot of your entire Rhino screen that may help. I want to make sure I have everything as similar as you to try and repeat the bug.


As far as I know, there are no plugins installed that are active within the

With my Rhino 5 installation I am using the following plugins:

  1. Brazil (latest release)
  2. Orca 3-D Beta
  3. T-Splines (latest release)
  4. Scan&Solve 2014
  5. Section Tools
  6. Grasshopper
  7. Paneling Tools
  8. SimLab 3-D PDF Exporter (older version) &
  9. BoltGen

A few years ago I was having some problems with Rhino and it turned out
that an evaluation version of Bongo 1 was the cause. As soon as I
uninstalled that, everything worked well. That is long gone of course.


Disregard the UPDATE that I added to my last email. I mistakenly opened
the file in Rhino 5. I just opened the file in the latest WIP, and the
problem is still occurring.


I saw an example the other day in which display mode, especially shadows, and being in a layout played a big part in performance. Just saying it’s pretty hard to track this kind of thing down without all the info

Hi Dennis - does this delay occur in any display mode?


So far I’ve only used shaded mode. I haven’t tried the procedure in any of the others.

@adek, @dmoyes is the current WIP still slow for you?

I’d agree that it’s memory related. Would add that WIP may be using a lot more RAM than previous versions

Yes, the latest WIP still takes several minutes to transform the set of curves that I submitted in my example file. I have not experienced any noticeable performance issues with other large data sets, and RhinoV5 still transforms the example curves within a few seconds. Whatever is causing the problem seems to be very particular to my installation of the WIP.

Did you ever send me and example file? I may have lost it in my inbox, sorry

Steve, I did submit the file containing the data that was causing the problem.

After receiving your email I intended to resubmit the file after doing a little more digging to see if I could track down any bad geometry. However, since installing the 9/19/17 WIP, I can no longer reproduce the problem. I can now transform the data set without any significant delay. As far as I am concerned, the issue that I was experiencing has been resolved. Thanks!

1 Like