New ticket id throws error

We are having problem with new ticket id. We have developed a solution where we were successfully using an existing, working ticket id.

We introduced some changes to the model so we created new one with a new ticket id.

Only changing the ticket id in our code makes following error to appear during shapediver initialization:

We are using the newest version of the viewer library:

This is the code that we are using to initialize the shapediver:

Unfortunately neither then nor catch from lines 507 and 512 are
ever called so looks like the promise. If I add debugger to the createShapeDiverSession() method it behaves as on attached gif below - neither then nor `catch are called in this method.

shapediver_error

Could you share a codesandbox which allows to reproduce the problem? (sending a link via PM is fine)

Are there any errors showing up on the network tab?

Hi Alexander,
Unfortunately we can’t share a codesandbox example because this ticket id is whitelisted with our domain only.
There are no errors in the network tab.

I can try to create a login so that you can access the stage environment of our site.

1 Like

@snabela PM sent.

Adding the example of how the old ticket works here for reference aswell.

https://www.screencast.com/t/WNNsFEJemHK

The error happens inside three.js:

It appears that for some reason the Request constructor gets overridden by your application. I would recommend that you investigate why this is so.

This part of the code is called in order to load the environment map. Likely no environment map was configured for your previous model. You can change or deactivate the environment map on the edit page of the model. You could try to set the Environment type to None. This might solve the issue, however other parts of the code might fail due to the missing Request constructor.

1 Like

Thanks for the input @snabela will check this and get back to you. :slight_smile:

1 Like

The error did change @snabela

bilde

@Andthocom, just to be sure, is it correct that you did the following:

  • Change the environment map to “None”
  • No other changes

Which version of the viewer are you using? In case it’s not the latest, please try.

Client did this, but he assured me it was set as you asked. He then sent me the new ticket id.

Verifying version now.

Please share the ticket or a link to the model in a PM.

Its the same details as previusly sent on PM. I can send you the ticket there aswell. :slight_smile:

Thank you! The model loads fine on our platform, viewer version 2.7.9 (the latest one).

1 Like

We seem to be back in business, setting environment type to none and using latest version did the trick.

Great, many thanks for your feedback!

1 Like