New Rhino instance, loads with default preferences

rhino
bug
v6
unhandled

#1

Hi,
Using updated V6,
When opening a new instance of Rhino by clicking a file (V6 or V5) Rhino loads with default preferences settings,
Popup menu, Aliases. Keyboard shortcuts, etc…
Only when i opening a fresh Rhino Instance, then opening the same file, i get my personal preferences.
Help ?
G.


#2

Do you mean that even though you saved the file with preferences different from the defaults, it is re-opening with the Rhino defaults?

Which specific V6 build are you using?


(Wim Dekeyser) #3

Hi Gil - have you tried starting Rhino by using “Run as administrator” once, then close that session and then trying your procedure again? Make sure that you don’t have any running instances of Rhino running before you do this - check the Task Manager to be sure.

image


#4

Hi,
Using Version 6 SR10 (6.10.18311.20531, 11/7/2018)
yes, even when saving them with my preferences & closing.
When i load them trough a new Rhino session, they get my preferences, but when doable clicking them to load, they load with Rhino defaults. mostly those are V5 files that get opened with V6.


#5

Hi,
Tnx, did that just now, for now still not solving the case…


(Wim Dekeyser) #6

It almost sounds like you have 2 different installations of Rhino on your system.
Any ideas, @brian?


#7

Well…i do have a V7 WIP & a V5 installed…:thinking:
The V5 is needed, the WIP can be removed…
Will do that and report.


(Brian Gillespie) #8

My guess is that when you double-click the 3dm file, Rhino WIP is opening, not Rhino 6.


#9

Nope…thats not it, my V6 loads, removed WIP, still not solved…
Really annoying…:confused:


(Wim Dekeyser) #10

Do you start Rhino 6 manually by clicking an icon on the desktop (when not opening a file from windows explorer)? If so, what does it say for Target in the Shortcut tab of the icon properties?

Also, have you tried making sure that the Opens with target that you see on the General tab when you look at the properties of a Rhino file in windows explorer, points to the same exe file?


#11

Rhino icon properties>Target “C:\Program Files\Rhino 6\System\Rhino.exe”
Rhino file properties> General> opens with> Rhino 6, there’s no Target over there…but does refer to the right software.


(Brian Gillespie) #12

@Gil_K there’s a feature in Rhino that allows different shortcuts to start Rhino with different “schemes” (probably should have been called profiles). I wonder if the different ways you are starting Rhino result in different schemes being started.

To find out, please do this:

  1. Open My Computer
  2. In the Address bar, paste %APPDATA%\McNeel\Rhinoceros\6.0\Settings
  3. Press Enter

You should see two files there:

  1. settings-Scheme__Default.xml
  2. window_positions-Scheme__Default.xml

Do you see others? If so, what names do the files have?


#13

Hi @brian tnx for replying,
looked it up & found a few more… some related to my RhinoGold plugin,
Attached a screen capture,
Capture
Maybe this will shed some light at this issue…
G.


(Brian Gillespie) #14

Hi @Gil_K, yes, my guess is that this is related to an interaction with RhinoGold. I don’t have it on my machine, so I don’t know for sure. @Trav I know this is a bit outside your wheelhouse, but closer to yours than mine - do you have any ideas for Gil?


(Travis Serio) #15

@Gil_K If I understand correctly it sounds like the Rhino scheme that you work in daily is not the Default scheme but most likely the RhinoGold scheme. As Brian mentioned when windows loads your 3dm file the Default scheme gets loaded. What you could as a quick fix would be use the OptionsExport command while running the scheme that has all of your favorite settings in it and saving them to file. Then start the up Rhino by double clicking a 3dm and using OptionsImport to import the other scheme settings. These wouldn’t stay in sync but would get all of your daily settings moved over. My guess is if you were to right click and go to properties on the Rhino shortcut that loads the proper settings youd see a “scheme=somescheme” in it somewhere.


#16

Tnx @brian & @Trav
Well we are making some progress,
First i’v renamed the RhinoGold *.xml to *.xml_bak, since i work trough Rhino interface, not RG.
Did a test, loaded Rhino trough quick launch icon (with the right settings) and closing,
settings-Scheme__Default.xml
window_positions-Scheme__Default.xml
got updated (timestamp changed)

loaded Rhino by clicking a file, the file was loaded with wrong settings, closed that,

  1. settings-Scheme_.xml
  2. window_positions-Scheme_.xml
    got updated.

So as i understand Rhino is working with two different sets of Scheme instead of the Default Scheme,
I prefer solving that and working with one Default Scheme and for that would not use the export workaround @Trav suggested.

As well did another test, renamed
settings-Scheme_.xml
window_positions-Scheme_.xml
to *.xml_bak, didn’t help, a new set of files was created & issue not solved.