New layer and move an object to the new layer issue


#1

It apen also in rhino 5, i’ts not to heavy.
Many time I imprt step file that are often divided in blocks, but not in layer, so.
-Unblock all polysurface
-Create new layer
-Select one polysurface
-Change the layer proprieties of the object to the new layer.
But at this point the new layer that I create before, are not listed. The only thing I can do, is, put the new layer as current to find the layer in the propriety list.

Thank you.

Marco


(Brian James) #2

I’m not seeing this here with Step files. Can you provide a Step file where this happens?
Just to confirm, the steps are…

  • Open Step
  • Explode any blocks to polysrfs
  • Make a new layer in the Layers panel
  • Select a polysrf
  • In the Properties panel use the layer drop down to move the selection to the newly created layer… this is when you don’t see the new layer in the list.

#3

Assieme Portastampo.stp (741.5 KB)

Below a quick video.
Attached to this reply the file.
-select the part
-create a new layer
-switch of
-go to properties
-there is not the new layer
-come back to the layer tab
-again to the properties tab
-the new layer appeare

Thank you

Marco


(Wim Dekeyser) #4

@BrianJ, I was able to reproduce it here. It didn’t happen the first time around but then I put my layers panel next to the properties panel as was in Marco’s video and used a factory-default “large objects mm” template.

There is no command line in the video, but I import the STEP file by drag’n’dropping it from explorer, zoom extends, explode the block, select one object, make new layer (hitting Enter to accept the name), turn off the layer, and go to the Properties Panel.

Notice here that the default layer is said to be red but it actually is black - this is correct in the drop-down menu. But the new layer - and default layer 5 are not visible in the drop-down.

I then put the object on layer 4 and then hit the drop-down again. Now all layers are visible in the drop-down.

Video in WMV format doesn’t attach to the forum so I zipped it:
NewLayer.7z (2.7 MB)


#5

well explanation.
I really go too fast with the mouse. :slight_smile:


(Brian James) #6

@JohnM have you seen this one? I’ve been trying for a while to reproduce it but not having any luck. both WIM and Marco have posted videos and although the sequences are a little different I can’t seem to hit the same bug here. Do you think it might have to do with the OS?

Here’s what I see… Layer in Props.zip (2.3 MB)


(Pascal Golay) #7

I’ve tried this a few times and I’m not getting it right either.

-Pascal


(John Morse) #8

I have tried using both work flows and have not been able to reproduce the bug either. I don’t think it is OS related, more than likely is has something to do with an event watcher. I will poke around some more.


(Wim Dekeyser) #9

Just to be sure - at first I didn’t get it to happen either but then I (1) used a factory-default template (large/mm) and (2) organized the layer and properties panels the way Marco had them (I don’t normally have them that way).


(John Morse) #10

I did those things as well but will try again.


#11

Take a look at this video.
I’m not able to let you see the drop down menu of layer etc. (can someone suggest some desktop recording app) but I think is almost clear about with the notes in the video.

This kiind of bug appen starting from rhino 5 even, I’ve tryed this in 4-5 different pc.

Thank you

Marco


(Pascal Golay) #12

Darn… I have been as careful to follow along as I can, and I do not see the same behavior here. @BrianJ, did you have a try following along Win’s clip?

-Pascal


(Brian James) #13

@pascal No I have not been able to reproduce this. In Marco’s latest video I also don’t see the layer drop down in Properties when he returns to that panel the second time.


#14

I’ve some problem with the screen recoder software. For this you can’t see the drop down layer menu.
Can ayone suggest something better?

Rega


(Brian Gillespie) #15

@marco, @wim do either of you have third party plug-ins loaded? If so, which ones? I wonder if there’s something at play there.


(Wim Dekeyser) #16

@brian,
not that I’m aware of unless you consider Cycles, Iris, … to be 3rd party.

I recall a recent thread where it was stated that this might not be a reliable list. Do you want me to check something else?