New file has 'something' done to it -- Can't close without save?yesORno

when opening a new file, something(?) has been done to it so you can’t simply close it without the SaveAs dialog popping up and asking for a name etc…

ie- here’s a screenshot from a new file… the red button has a black dot in it and the title shows ‘edited’ (indicating the file has been worked on… even though the undo stack is empty at this point)

which leads to this upon closing:

… when it should just simply close.

i tried it with a fresh .plist (nov24 build) as well as tried it on my laptop using my custom template as well as the default template… behavior is the same in all cases.

Yeah, noticed this today as well with a student’s Mac. --Mitch

Bug logged in MR-1097.

i just tried opening my normal template, then without doing anything else, saved that as a new template… and now i can open/close the new template without a problem.

oh… sometimes i can see the jetbrains and sometimes i can’t… with that one :point_up:, i can’t.

Hi Jeff-that one was set to ‘Developer’, I changed it to ‘All Users’; you should be able to see it now. Most of the reports linked here on discourse should, I think, be set to all users if there is no reason (like confidential info or something), but it is easy to miss when reporting a bug and the default setting seems not all that consistent in JB.


yeah, i figured it was something along those lines. thanks

Fixing this problem marked all template files as modified when they were opened. This will be fixed in the next WIP release.