*NEW* Eddy Beta Released

Hi All,

After a very long time, and many of you asking about the new eddy version, we are very happy to release the version of Eddy. This is a beta version, and on the website you can download it, as well as the stable long term release.

The major features of this new version are :

  • Indoor Air Simulation Modules
    -Updated to work with the latest BlueCFD 2020 (Note you will need to download this to work)
  • Updated and improved MRT calculations

We are also happy to have a new external collaborator, Tobias Holzmann. We are very excited about this!

Enjoy, and as always please inform us of bugs or questions.


Thanks for the update. Can we have working examples with the new modules introduced. Existing template is missing new examples!

I’ll pass this along to the dev team responsible for the examples.

1 Like

I downloaded the the version of Eddy, I can’t seem to have it working in GH. I have tried Uninstalling and Installing 3 times at this point.

Let me know what i might be doing wrong here. Thanks!



Hi Somesh,

Please try the following :

  1. Right click on the Eddy file (The green one in the image above) and click properties, and make sure the file is unblocked.

  2. You can try putting the Eddy GH file into the special folders on rhino if that still doesn’t work.

If you still have issues then let me know and we can open an issue on our github for it.
Make sure BlueCFD2020 is installed too!

Thanks for prompt reply on this remy!..

I don’t see any Unblock option on that file, I even checked before installing that the Installer itself is unblocked.

What all do i have to copy from Eddy 3D folder to the special folder? only GH file?

When i pasted the GH file in “Component folder” i am getting this error.


I have BlueCFD 2020 installed too!


Try just copying that one file you have selected into the components folder. Check the security tab for unblocking. If there is no option that means it is already unblocked.

If this does not solve the issue then I am not sure what it could be and Ill ask our devs.

Yes, I did and got this error.

Hi @Somesh . I can suggest something on this.
Try uninstalling eddy 3d new and old version completly. Even uninstall old blue cfd 2017. Only keep 2020 version. While installing try running with administartor rights. Hope this works

Hi @asisintel I actually did that. I Uninstalled both Eddy and BlueCFD 2017 that i was using and Installed new version with CFD2020 with Admin rights. Did it 3 times…cleared temporary files…restarted after each install and uninstall…I am baffled why this happened.

Thanks for the tip tho!

I’ve sent this issue to our Dev, and waiting on a response, Somesh.

1 Like

Thanks a bunch Remy!

hey, Somesh
Did you install the file with other admin account?

No, I cleared any previous installs and their temporary files & Installed the latest patch but still couldn’t see the plugin on grasshopper so i copied this time the following 2 files…Restarted the Rhino and it works perfectly fine now.


The solution was suggested by @Patrick Kastner (Eddy Beta version not working in Grasshopper. · Issue #3 · EnvironmentalSystemsLab/Eddy3D-Public · GitHub)

cool cool, thanks for the information!

Hi Remy,

It seems like the examples are still using 0.3.8 version and when I replace them with the new version, one by one, it does not work on Rhino 7.

dircalc3 command failed with exit code 1: system - cannot open file ‘Rad\output\dcd_r1.mtx’: No such file or directory

I tried to make a very simple case to test MRT. I am getting stuck after running the MRT System component. I don’t really know what to do next.