Network surface

Hi there!

I was trying to create a network surface but have no errors return and nothing return which means not successful

script

According to the rhinosyntax shown as picture I shall use the guid, and according to mt print output, it is a guid list, but still get no results both visually and in document. Make me really lost.

Hope there is a way at least to know where went wrong not even mention to fix it.

Thanks for your valuable time! Any discussion or opinion I would appreciate a lot!

Good day!

Hi,

Could it be the networksurface cannot be created from the input curves resulting in None as return value?
There is no error return to b expected if the creation fails just the None

Can you provide the curves you input so we can replicate your issue?

-Willem

1 Like

Hi Willem,

Thanks for replying, and yes I’m struggling why it cannot work.

These are curves that make the network surface work manually. As seen in the screenshot, there 3 different color group, the order of red groups, the array order is from the bottom left, along with the contour, all the way up and then down, ends at the right bottom.

I tried different orders: green - blue - red, grb, rbg ( becuase I feel blue and the green are basically the same property - a contour curve), but still cannot return network surface successfully, which still a none.

Kind regards,
Wen

Wen, can you post a .3dm file with the curves?

1 Like

Hi David,

Thanks for replying!

I tried to select from GetObjects instead of using guid by tracking from the before and it works, so I guess it’s where went wrong! Gonna take a look on it!