Network Licence not working properly

unhandled

#1

Hello, we have a strange problem since the last update. Every new session, VisualARQ starts ulicensed, displaying the following message:

VisualARQ: The command ‘VAWALL’ will not run because there are no available network licenses. Please restart Rhino in order to acquire a new network license or run ‘vaLicense’ command to change your license mode.

When I cehck the zoo server, I can see that the licences is still assigned even after closing rhino. The only way to make ti work is to activate the “viewer” mode, restart rhino, change the licence back to “Network” and restart rhino again. Any idea of why?


#2

@XDGA What VisualARQ version are you running? make sure you have the last 2.0.17 version before trying anything else.


(Enric Marquès) #3

Hi @XDGA.

If the Zoo Server shows the license as “In Use”, VisualARQ will not be able to get a license. You need to recover the license first: http://docs.mcneel.com/zoo/5/en/index.html

Sometimes licenses are not returned and they are locked forever until you recover them.

Enric


#4

Hi, we’re using version 2.0.17.11944 and zoo6


#5

The problem seem to be resolved with just stopping the Zoo server for a few minutes. I will let you know if it comes back; thanks for the help


#6

I still have the same problem. The licence looks correctly assigned to the user on the ZOO, but Rhino says that there isn’t any available licence


(Enric Marquès) #7

If the Zoo Server shows a license as “In use” and shows a user name, that means that the license is taken nad cannot be used until it is released. A license is automatically released when Rhino is closed. Maybe your Rhino crashed and the license wasn’t released.

You can recover the license in the Zoo Server so it can be used again by the same (or another) user.

Enric


#8

Hi Enric, I understand your point. The problem is complicate, and I am not sure that it is even related to the recovery procedure. It seems a problem of communication with the zoo

  1. The licence stays assigned even after closing rhino, and this now happens all the time
  2. We have two licences, and even if the one is stuck/busy, the one that is free doesn’t get assigned.
  3. If I run the VaLicence command, there is a message saying that the software is running in unlicenced mode
  4. Recovering the Licences doesn’t reassign it either.
  5. the only way of making it work is to re-authorize the licence, which means changing to viewer and then back to network licence
    we are running the Zoo server 6

#9

After, this modification is done, the licence stays assigned in the zoo (even after closing rhino). Even more strange, if the licence is recovered, then a new session of Rhino assign it correctly this time. I suspect it is something that happens with the communication with the zoo after a long period of time (one day or more)


(Enric Marquès) #10

Hi @XDGA,

If you run several instances of VisualARQ on the same computer, only one single license will be assigned, and until you close all VisualARQ instances, it won’t be released.

VisualARQ only tries to get a license from the server at startup, so if you recover a license from the Zoo Server, it will not be assigned until you run a new instance of Rhino/VisualARQ.

Many other users are using VisualARQ with a Zoo Server, and they are not reporting this issue. Can you please tell me the exact version of Zoo you have installed? You can check it using the About dialog in the Zoo Admin. I’ll try to reproduce your issue here in my office.

Regards,

Enric


#11

Hi Enric, thanks for taking the time to check;
We are using Zoo 6.0.15149.9391
I am sure that others have no problem, and I am sure it works because it did so for us before the last update.
At the moment I have an even stranger issue, with visualarq licenced and running normally, and the zoo reporting no licence being used:


#12

I will try to update the zoo, as I see we have a very old version


#13

ok, so just to report that one day and a night have passed and the situation is back to no licence available.
Both the machine and the Zoo Server machine rebooted (now the zoo is updated to version 6.0.18009.02391)
But visualarq licence says:

01

and the licence on the zoo server is still assigned to the user (even after both machines restarted)

recovering the licence didn’t help.
Forcing Visualarq to relicence is the only way to make it work.


#14

So I confirm that for a third day in a row, the problem is there, replicating always as described above


(Enric Marquès) #15

Hi @XDGA,

I’ve been trying to reproduce your issue, but I haven’t been able. I’ve tried using:

  • Rhino 5 SR14
  • VisualARQ 2.0.17
  • Zoo Server 6.1.18037.13441
  • VisualARQ Zoo Plugin 2.0.17

The first problem you have is that it seems Rhino/VisualARQ is not closing correctly, and the license is not released. This may happen if Rhino crashes, if you kill the process, or if there is no active network connection between the computer (Rhino) and the server (Zoo) when you close Rhino. In this situation, the license will be “In Use” by the user and the computer… forever. Only the same user on the same computer will be able to get this license from Zoo, but it will not be never released, even after closing Rhino, as the use count will not reach 0 never. Restarting the Zoo Server or the computer where Zoo is installed will not release the license neither. The only way to get back this license to use the “Recover” option in the Zoo Admin.

But it seems you have two VisualARQ 2 licenses, one “In use”, and another “Available”. In this scenario, VisualARQ should never give you the error “Network license unavailable”.

Are you using VisualARQ from more than one computer? If yes, does this happens on all computers?

Enric


#16

Hello Enric. Indeed the problem seemed to be connected to just one machine.
All worked as expected for a month on a new machine, but now we are back to the same problem. For some reason the licence stays assigned, and the other licence is not assigned. the only way to solve it is:

  1. start rhino (licence not assigned)
  2. change to viewer mode and restart rhino
  3. change to network mode and restart rhino

configuration:

  • Rhino 5 SR14 64-bit
  • VisualARQ 2.0.18
  • Zoo Server 6.1.18078.10031
  • VisualARQ Zoo Plugin 2.0.18

(Enric Marquès) #17

Hi @XDGA,

Is Rhino, on this machine, also retrieving its license from the same Zoo Srrver? If yes, does the license gets released when you close Rhino?

Enric


#18

yes, the machine is also using the zoo server, and yes after forcing the network licencing, the licence is released. At the same time, I see there is quite of a lag in releasing the licence


#19

Dear @enric, we are still bothered by this problem. We are going to investigate if it is a problem related to our firewall. Could that be a reason?
It is really annoying but litterally every day the licence has to be reassigned (which essentially means restarting rhino 3 times)


(Enric Marquès) #20

Hi @XDGA,

I’ll have to ask McNeel about this issue, because VisualARQ is using the Zoo SDK to retrieve licenses from the Zoo Server. VisualARQ is only calling some functions from a Rhino service called “Zoo Client”, and this service is the responsible to contact the Zoo Server. I’ll let you know if McNeel have any clue what is happening in your case.

Do you have more that one computer using VisualARQ? If yes, Is this issue happening in all of them?
Do you have any other plugin installed that is also using Zoo licenses?

Thanks,

Enric