Net 4.8 framework in conflict with rhino 7 update

Hi there, i have since yesterday the problem that rhino 6 & 7 doesnt want to start. It happend, after it came the suggestion for an Rhino 7 update, so i downloaded and startet the update... it failed. I tried everything, contacted technical support, followed all of the steps provided and nothing helped. Could you help me, im working on a competition at the moment and need it urgently …

Your best best is to run the Microsoft .NET framework repair tool, then run the Rhino installer again.

Any luck?

i tried this one several times … didn`t work


That would indicate your Windows installation is pretty messed up.
I think your best option is to re-image the system, get it updated, and install Rhino again.
If it’s an older computer, it might make more sense to replace it.


no the PC is not that old, 3 years
Intel(R) Core™ i9-7900X CPU @ 3.30GHz 3.30 GHz
32.0 GB (31.7 GB usable)
64-bit operating system, x64-based processor
NVIDIA GeForce GTX 1080
Windows 10 Pro
Version 21H2
OS build 19044.1526
Windows Feature Experience Pack 120.2212.4170.0

So if it were me, I’d restore it to factory defaults, apply the Windows updates, and reinstall Rhino.

everything worked quite properly till yesterday, i had quite big files open and all was fine … till the update…
how can i check if the windows OS the issue is …

You might see if the system created a restore point before the install of the problem update. If so, try restoring to that point. Might avoid the necessity to reinstall Windows from scratch.

rhino 5 and rhino 6 are functioning … only 7 makes the problem


this was the framework message:









C:\Users\User\AppData\Local\Temp\Microsoft .NET Framework 4.8 Setup_20220214_232514381.html

C:\Users\User\AppData\Local\Temp\Microsoft .NET Framework 4.8 Setup_20220214_233815934.html

C:\Users\User\AppData\Local\Temp\Microsoft .NET Framework 4.8 Setup_20220215_064716291.html

C:\Users\User\AppData\Local\Temp\Microsoft .NET Framework 4.8 Setup_20220215_070029114.html

C:\Users\User\AppData\Local\Temp\Microsoft .NET Framework 4.8 Setup_20220215_070234833.html



I was also able to install Rhino 8 WIP and it loads all of the plug-ins ( from 6 and 7 ) and works … only 7 makes the mess …
I received this update rhino_en-us_7.16.22045.01011 from the support team, after trying to install it something happend …
on my laptop the newest available update version is rhino_en-us_7.15.22039.13001
could it be something wrong with this new update ?!