Nested Block Layer not responding


#1

I think this is a bug. If you have 3 levels of nested blocks, the lowest level block will not turn off with it’s layer. Objects inside that block will turn off with their own respective layers, but the block will not turn off with its layer. To try to illustrate more graphically:

Block 1: Layer Block 1
Block 2: Layer Block 2
Block 3: Layer Block 3
Objects: Layer Objects 3

The objects within Block 3 will turn off when “Layer Objects 3” is turned off, but not when “Layer Block 3” is turned off.


(Brian James) #2

Hi Jacob,

Can you send an example with the associated blocks to tech@mcneel.com please? Please also indicate what layer you are trying to turn off if you can. Thanks for the feedback… just trying to reproduce this as you see it.


#3

Hi Brian,

Sorry, I meant to respond to this a couple weeks ago, but I got tied up with other things. In the attached file, turning off layer: Object 3 makes the smallest box disappear, but turning off layer: Block 3 does not, even though the smallest box is in a block that is on that layer.

Jacob

Block nesting example.3dm (31.0 KB)


(Brian James) #4

Hi Jacob,

Did you mean that turning off Layer: Object 1 should hide the smallest block?

I see the smallest block as being part of Layer:Object 3 here but don’t see the smallest block as part of Layer: Block 3.


#5

in the attached screenshot, the block on the right is the original with Layer: block 3 turned off

The block on the left has been exploded once. Nothing else. Block 3 is now off, like I would expect it to be.

We’ve been working around this issue but would love to see it fixed.

Jim


#6

@BrianJ in your screenshot the object you have selected is an extrusion, not a block. If you are working in Block 2 and select Block 3, you will see that it is on layer “Block 3”

j


(Brian James) #7

Thanks for clarifying Jacob and James. I’ve got this issue filed now as RH-23297 for future reference. Thanks for bringing it up, development will need to take a look.