Neon not working


#1

Hey All,
New to the forum so hi :smile:
I googled for this issue for quite sometime now and it is driving me mad…

I haven’t done anything and the ground plane and sun just don’t show in the viewport, no matter what configured on them.

When I change the view port to “rendered” its all fine again.

I am working with the latest neon on rhino 5.5.

The only close thing to something that might be related is a forum thread I found suggesting that under preferebces>view>display modes>retraced with neon, to check whether lightning method is set to “default” instead of “scene lightning”, but it isn’t, it is configured fine.

I tried checking other settings there but couldn’t find anything that would fix this.

Thanks a lot in advance, I need it for studies, needed it 4 hours ago…


#2

Has Neon suddenly stopped working or is this your first attempt?

Have you rebooted since installing? Try running repair on the Neon installer?

What OS (and 32 vs. 64-bit)?


(Brian James) #3

Hi Stam,

Check that you have the latest Rhino 5 service release installed and the latest version of the Neon plugin too. One other thought is that you may have the current rendering plugin in Rhino set to something that doesn’t support Neon and the ground plane and sun features of Rhino fully. Check the Render drop down menu>current renderer to make sure it says Rhino Renderer or Brazil.


#4

Hey,
I have been working with rhino and neon for a few months now, around 3.
Never had issues, I keep my OS updated but there wasn’t any lately.
I also don’t recall changing anything.
Had to go out for few hours I will check what you suggested once I get back :smile:

p.s: Im actually not the person who is using rhino, it is my girlfriend, I work at IT and trying to help her :slight_smile:
Great to see such a prompt reply to a question, awesome community


#5

i tried repairing the neon install it failed with a weird network access error although the file was saved locally, maybe it was the UAC settings as i didnt “run as administrator”.

I did however uninstall and reinstall, same issue…

i am 64bit win8 (not 8.1), i havent installed anything prior to that, it was working and stopped working, well i think it is a setting somewhere in rhino which is off, i am afraid of reverting back all settings to default because i am unware of which changes were made that i would hate to regret foretting them afterwards…


#6

i havent installed any update since i installed rhino and neon, so i really dont think updating it will solve it, i just downloaded neon again and tried repairing it to no avail… same issue… it is probably a rhino setting that is off…
are there any “set of settings” that you might recommend to check as a prerequisite to see the ground/sun??

i checked under the render menu, i hope you are referring to the top bar, where “file/edit/view” usually exist and not some other “Drop down” menu.
I only have one option there “Rhino renderer”, i do not have brazil installed, my girlfriend dont even know what that is…
mmmm… i do not see neon as a plugin, under that menu, but i think that is fine…

i am very certain it is just a viewport or render option that isn’t set…

again, using the regular renderer i do see the sun/ground and i can play with the settings and see it change in real time… its only the retracing with neon that doesnt show anything any change…

Thanks a lot for helping and again for swift responses you two had, much appreciated!! I’m also googling in the background, i am actually really good in finding answers, just not for this one i guess :smiley:


#7

Can you attach the file you are using in case it is specific to that?

Also, you should be able to copy the Raytraced with Neon - Display Mode and reset the copied one to avoid changing the current one. Rhino Options -> View -> Display Modes. Select Raytraced with Neon and copy it. Navigate to the new Copy and use the ‘Restore Defaults’.


#8

Oso - It doesn’t really matter the file, the problem was first seen on a bigger project, one that really has the objects my girlfriend is working on, but then we opened other files and even created a new file from sketch (“untitled”…), just created a box and tried it out…

If i run ‘reset to default’ it seemed like it reverts everywhere… is that true?
is there an option to copy the files directly from the filesystem to save the settings? like .cfg files? maybe under c:\users…

things dont just “change” like that… if we didnt update the rhino nor neon, i dont think a microsoft update for the operating system would do such a thing…
it comes down to rhino in my opinion and some sort of configuration… but yeah… maybe if “rendered” works ok and only that retrace view isn’t, it might be a setting there… i will try the settings copy and revert to default and update…

i also tried updating nvidia’s driver just now, she had the driver before it… also didn’t help…


#9

That is a question for BrianJ. It seemed fine when I did it but I am not a Rhino expert.


(Brian James) #10

Hi pixel,

I’m not sure, but perhaps the Neon plugin isn’t loaded and you are looking at the Rendered Display mode which the Neon display mode would revert to if Neon were not actually loaded as a plugin. Can you take a look in Options>Plugins to see if neon is there and if it is loaded?

In Options>View>Display Modes you can export an ini file which is the full list of display mode settings for the display mode selected. You can make a copy of a mode too here to experiment. I’m really starting to think that Neon just isn’t loaded in Options>Plugins. Please restore the Neon mode to it’s defaults, make a copy of what you have first to compare.

Please also update Rhino 5 to the latest service release. Lastly, if you can post screenshots of what you see when in Neon mode that will help determine the issue as well.